Contribute
Register

Acer Aspire V Nitro VN7-791G with Sierra (10.12.2) onboard

Status
Not open for further replies.
Joined
Nov 24, 2016
Messages
73
Motherboard
VN7-791G
CPU
i7-4720HQ
Graphics
Intel 4600HD
Mac
  1. MacBook Pro
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. Android
Hi.
Attached is my current CLOVER dir from EFI partition.
For config.plist variants please see post #25
 

Attachments

  • CLOVER-2.zip
    1.6 MB · Views: 114

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Do I have to make a line like in config.plist BOOT section?:
<key>Legacy</key>
<string>CSM</string>

No. This has nothing to do with Clover configuration... just BIOS options.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi.
Attached is my current CLOVER dir from EFI partition.
For config.plist variants please see post #25

Clover/kexts is wrong. You have no kexts there... therefore not possible to boot the installer/recovery. FakeSMC.kext is always required to boot.

SSDT-PluginType1.aml is not a good idea (you should have read the comments).
SSDT-IGPU requires GFX0->IGPU rename patch in config.plist.
SSDT-XOSI requires _OSI->XOSI rename patch in config.plist.
SSDT-EH01/EH02 requires EHC1->EH01, EHC2->EH02 renames.

See hotpatch guide linked from main ACPI guide: https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/

Your profile is not filled out. Refer to FAQ for details required.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
 
Joined
Nov 24, 2016
Messages
73
Motherboard
VN7-791G
CPU
i7-4720HQ
Graphics
Intel 4600HD
Mac
  1. MacBook Pro
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. Android
OK, So I manage to get OS X booting with custom Clover config.plist.

WiFi and ethernet both works with no issue. More over. -this post is made from HackMac.

Still there is a problem with display glitch (see post #26).
Please see attached report for further guidance\reference.

I have to understand how to fix HD4600 7mb issue\ boot problem.

P.S. system updated itself to 12.2.3 with no issue.
 

Attachments

  • CLOVER.zip
    1.8 MB · Views: 78
  • diag-2.zip
    3.1 MB · Views: 55

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
OK, So I manage to get OS X booting with custom Clover config.plist.

WiFi and ethernet both works with no issue. More over. -this post is made from HackMac.

Still there is a problem with display glitch (see post #26).
Please see attached report for further guidance\reference.

I have to understand how to fix HD4600 7mb issue\ boot problem.

P.S. system updated itself to 12.2.3 with no issue.

Please fill out your profile as requested in the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html


If you have an issue, describe it clearly and concisely.
And provide typical "Problem Reporting" data.

Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda

Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /

Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
 
Joined
Nov 24, 2016
Messages
73
Motherboard
VN7-791G
CPU
i7-4720HQ
Graphics
Intel 4600HD
Mac
  1. MacBook Pro
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. Android
Please see post #37 for requested data.

If it possible - could you check if any file missing\wrong?

I will activate disabled rename\patch as stated here later https://www.tonymacx86.com/threads/fix-resolve-boot-screen-garble.175799/

The next step will be (I know -all covered in FAQ):
  1. Power manager
  2. Sound
  3. Bluetooth
My question is about 2 devices, that are on PCI0 bus: 8086:8c3a and 8086:c04 (see diag-2 attachment for IOReg). Seems like that are chipset controllers (Chipset Family MEI Controller and Processor DRAM Controller respectively). Should I do something with them or not?
 
Status
Not open for further replies.
Top