Acer Aspire S3 Ultrabook WLAN and Bluetooth problem

Discussion in 'Lion Laptop Support' started by samui67, Dec 4, 2011.

  1. samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Dec 4, 2011 at 2:05 AM #1
    samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Hi together,

    after many sleepless nights i managed to get installed MacOS 10.7.2 on my notebook.
    But i still have 2 problems:

    I cannot get my wireless Atheros AR5BWB225 with the AR9285 and / or AR9287 drivers working. If i use the Atheros fix it always ends up in a kernel panic, so that have to restart in safe mode (-x) and replace with the original AR92xx kexts, i did choosen and installed before, for can boot up in normal mode again.

    [EDIT] found now with Ubuntu lspci command, that the Network card is an AR9485, but still need a solution...

    My second problem is related to the Bluetooth:
    The Bluetooth is showing and i can switch it on and off so that i can search for devices. But still cannot detect any device, like e.g. my mobile phone or Bluetooth Headset.

    Every help for could solve this issues would be very appreciated.

    Thank you all in advance very much...
     
  2. Allnutz

    Allnutz

    Joined:
    Dec 5, 2011
    Messages:
    1
    Dec 5, 2011 at 2:14 AM #2
    Allnutz

    Allnutz

    Joined:
    Dec 5, 2011
    Messages:
    1
  3. bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Dec 6, 2011 at 1:08 PM #3
    bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Hi samui67

    I too got my Acer S3 running well on Lion 10.7.2 (full QE/CI)
    I noticed you said you had only 2 problems.... wifi and bluetooth..
    What about Sound.... I could not get mine to work with Voodoohda.kext...
    It shows the sound control on the top menu and i can adjust the volume but no sound actually comes out of the speakers :(
    What did you use for sound?? may i ask....

    Currently... there is also no brightness control on my machine and the fan is constantly running.. It heats up quite a bit after prolonged use....

    I resolved my wifi problem by using an ASUS N-10 usb wifi dongle (it's way small) and when attached to the back port of the S1.. you dont even notice it... :)

    Let me know if you see this message... THanks

     
  4. samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Dec 7, 2011 at 2:09 AM #4
    samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Hi,

    first of all, sorry for my late reply...

    @Allnutz
    Thank you very much for your help. I tried this already, without any success. There seems to be much differences between the Atheros 9285 and 9485.

    @bd4utonite2
    I used the ALC269 kexts from here: http://www.osx86.net/downloads.php?do=file&id=1283

    May i ask you, which kexts you are using for the ASUS N-10 usb wifi dongle?

    Best regards
     
  5. bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Dec 7, 2011 at 1:06 PM #5
    bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Hi

    The voodoohda.kext does not work for me.. I can adjust volume but still no sound. Did you delete AppleHDA.kext in your setup??
    Can i ask you what bootloader you are using... i myself have installed Chimeria 1.4.1 r877

    For the Asus N-10 usb dongle.. just go to http://www.asus.com/Networks/Wireless_A ... /#download
    select Mac OS... and install the 10.6 package provided by them... disregard the 10.4 and 10.5 packages. :)

    cheers...

     
  6. samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Dec 7, 2011 at 1:21 PM #6
    samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Hi bd4utonite2,

    i am booting with Chameleon Bootloader in a Dual System from my Windows 7 Partition.
    I used the basic "Chameleon Install 1664" Windows installer and replaced the wowpc.iso with the wowpc.iso "Chameleon_2.1svn_r1700_trunk_SNB_HD".
    If this Kext File is not working for you, there are also some others, you can download there.

    About the WLAN: Today i bought a much smaller and i guess also cheaper one from D-Link, which also has support for MAC.
    About the Bluetooth: I bought a cheap Bluetooth USB Dongle nearly similar small size. So this is finally also working for me.

    Best regards
     
  7. bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Dec 7, 2011 at 1:57 PM #7
    bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Hi Sammi...

    It is definitely the boot loader then for sound that is......
    My rational is... i upgraded to Chimera 1.6 from 1.4.x (1.5 does not give me qe/ci)
    Once in Chimera 1.6, Bluetooth was automatically detected and is working... it was not in Chimera 1.4

    I have a dual boot Acer S3 core i5 with win7 ultimate... I voided my warranty by swapping out the slowwwwwwwwwwww 320gb hitachi drive for a 160gb Intel 320 series SSD... By the way..... be sure your ssd is 7.5mm thin... standard ssd are normally 9.5
    Just a tip for you if you decided to go my way :)

    cheers....
     
  8. bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Dec 7, 2011 at 3:31 PM #8
    bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Hi again.. Sammi

    Can you point me to Chameleon_2.1svn_r1700_trunk_SNB_HD??
    I can't seem to find this on the net... weird right???

    Ta mate...

     
  9. samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Dec 8, 2011 at 11:49 AM #9
    samui67

    samui67

    Joined:
    Nov 22, 2011
    Messages:
    6
    Hi bd4utonite2,

    "ta mate" sounds chinese, right? ;)
    I got it from this Forum: http://bbs.pcbeta.com/forum-lion-1.html

    If i won´t need the 320 GB hard Drive for my data, i always have to carry with me,
    i also would change the HDD and replace with a super fast SSD, like you did. It´s really a great idea!

    BTW: I went back to Snow Leopard. In my opinion its much faster, but now i have a problem with ALC269 installation there :banghead:

    Best regards
     
  10. bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Dec 8, 2011 at 11:57 PM #10
    bd4utonite2

    bd4utonite2

    Joined:
    Feb 15, 2010
    Messages:
    84
    Mobo:
    Acer Aspire S3-951-2464G34iss
    CPU:
    Intel Core i5 2467M / Mobile Intel® UM67 Express Chipset
    Graphics:
    Intel HD Graphics 3000 1366x768
    Mac:
    iMac, MacBook, MacBook Air, MacBook Pro
    Mobile Phone:
    Android, iOS
    Ta mate.. is Australian.... it means thanks buddy :)
    I see the bootloader that you are using can only found in China forums.
    Too bad for me as i cannot read chinese.

    This my first Acer notebook.
    I have done Thinkpad x61, x300 and Lenovo U460 without a problem for sound.
    In fact the U460 uses a ACL269 chipset as well and it works.

    By the way i always use tonymacx86 bootloaders.... that is iBoot, Chimera and Multibeast
    They are great :)

    Cheers
     

Share This Page