Contribute
Register

Acer Aspire E17 [was: Nvidia graphic acceleration not working!]

Joined
Apr 18, 2018
Messages
28
Motherboard
Acer Aspire E17
CPU
Intel i5-5200U
Graphics
Intel Graphics HD5500
Mac
MacBook Air
Hi,
I'm using Aspire E5-772G laptop.
IMG_20180426_002034.jpg
IMG_20180426_002109.jpg

  • i5-5200U 2.20GHz
  • 4GB DDR3 RAM
  • Intel HD Graphics 5500
  • Nvidia GeForce 940M
Recently i have followed so many tutorials on fixing graphics problems on hackintosh. Like,
and finally I get the Nvidia web driver running and the mac os sierra is able to recognize my graphic cards(as depict in picture).
But i still can't get my Nvidia graphic acceleration function properly and showing "Display 7MB". I think the problem was caused by two graphic cards in my computer and mac os choose the integrated graphic HD5500 to boot by default.

Can anyone help me out? I have attached my config.plist at the bottom.

Any advice would be appreciate!
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi,
I'm using Aspire E5-772G laptop.View attachment 327813 View attachment 327814
  • i5-5200U 2.20GHz
  • 4GB DDR3 RAM
  • Intel HD Graphics 5500
  • Nvidia GeForce 940M
Recently i have followed so many tutorials on fixing graphics problems on hackintosh. Like,
and finally I get the Nvidia web driver running and the mac os sierra is able to recognize my graphic cards(as depict in picture).
But i still can't get my Nvidia graphic acceleration function properly. I think the problem was caused by two graphic cards in my computer and mac os choose the integrated graphic HD5500 to boot by default.

Can anyone help me out? I have attached my config.plist at the bottom.

Any advice would be appreciate!
As per FAQ, discrete GPU in dual-GPU/switched configuration not supported.
Best you can do is disable it.
See details/links in FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Apr 18, 2018
Messages
28
Motherboard
Acer Aspire E17
CPU
Intel i5-5200U
Graphics
Intel Graphics HD5500
Mac
MacBook Air
As per FAQ, discrete GPU in dual-GPU/switched configuration not supported.
Best you can do is disable it.
See details/links in FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
I have followed the guide and successfully disabled my Nvidia card, but a new problem comes out.
When I set the ig-platform-id in config.plist to "0x19120000", the system can recognize my Intel graphic card(shown in the picture).
But when I set the id to "0x16260006" like many guides I found on the websites did, I get a splash screen and in the graphic portion of "About mac" it only shows "Display 7MB".

I've found so many guidance like those listed below
but I am not sure which is most suitable for my problem. I also tried following some of them to configure my graphic but nothing seems happen. Are they the right guides I should follow with?

In addition, I've disabled the discrete graphic card, only using the integrated Intel graphic card for mac so I don't need to use Nvidia web driver and Cuda driver any more, do I?IMG_20180427_225131.jpg
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have followed the guide and successfully disabled my Nvidia card, but a new problem comes out.
When I set the ig-platform-id in config.plist to "0x19120000", the system can recognize my Intel graphic card(shown in the picture).
But when I set the id to "0x16260006" like many guides I found on the websites did, I get a splash screen and in the graphic portion of "About mac" it only shows "Display 7MB".

I've found so many guidance like those listed below
but I am not sure which is most suitable for my problem. I also tried following some of them to configure my graphic but nothing seems happen. Are they the right guides I should follow with?

In addition, I've disabled the discrete graphic card, only using the integrated Intel graphic card for mac so I don't need to use Nvidia web driver and Cuda driver any more, do I?View attachment 328127
0x19120000 is not valid for Broadwell. Your images actually proves the graphics drivers are not loaded. Do not confuse cosmetic displays with actual working graphics.

See guide for correct plists:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Apr 18, 2018
Messages
28
Motherboard
Acer Aspire E17
CPU
Intel i5-5200U
Graphics
Intel Graphics HD5500
Mac
MacBook Air
0x19120000 is not valid for Broadwell. Your images actually proves the graphics drivers are not loaded. Do not confuse cosmetic displays with actual working graphics.

See guide for correct plists:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
Just to confirm, the glitches appeared on the screen is because of integrated graphics card QE/CI not working, and QE/CI not working is because of improper configure on config.plist. Am i understanding it right?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Just to confirm, the glitches appeared on the screen is because of integrated graphics card QE/CI not working, and QE/CI not working is because of improper configure on config.plist. Am i understanding it right?
Correct.
 
Joined
Apr 18, 2018
Messages
28
Motherboard
Acer Aspire E17
CPU
Intel i5-5200U
Graphics
Intel Graphics HD5500
Mac
MacBook Air
Following these guides to set my DVMT memory but glitching problem still remaining...
I have attached my problem reporting files, it would be grateful if you can help me find out where the problem came from.(I used patchmatic to get my origin ACPI tables, but I also attached my patched tables along with it because I used those patches to disable my discrete graphic card) I've been stuck on graphics problem for almost a month:crazy: Thanks a lot!
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Following these guides to set my DVMT memory but glitching problem still remaining...
I have attached my problem reporting files, it would be grateful if you can help me find out where the problem came from.(I used patchmatic to get my origin ACPI tables, but I also attached my patched tables along with it because I used those patches to disable my discrete graphic card) I've been stuck on graphics problem for almost a month:crazy: Thanks a lot!
"Problem Reporting" files are wrong (as per FAQ, must be in ZIP format).
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Apr 18, 2018
Messages
28
Motherboard
Acer Aspire E17
CPU
Intel i5-5200U
Graphics
Intel Graphics HD5500
Mac
MacBook Air

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have regenerated the problem reporting files using the tool you recommend. As shown in the attach.
EFI/Clover is missing from this ZIP.
 
Top