ABWB Wifi & Bluetooth Card keeps preventing sleep :(

Discussion in 'Network' started by flyguy, Oct 7, 2016.

  1. vin047

    vin047

    Joined:
    Jan 18, 2017
    Messages:
    5
    Apr 20, 2017 at 11:15 PM #31
    vin047

    vin047

    Joined:
    Jan 18, 2017
    Messages:
    5
    No don't sadly, hence why I was asking if it did work for you i'd appreciate knowing - then I could rule out the Fenvi card as the issue. I've tried fiddling with DSDT/SSDT, clover config etc but nothing seems to have worked.

    Regarding 5GHz internet connectivity - I can confirm that I didn't have any such issue with either Fenvi or ABWB card. I'm using 5GHz on Apple Airport Router if that makes any difference.
     
  2. UtterDisbelief

    UtterDisbelief

    Joined:
    Feb 13, 2012
    Messages:
    878
    Mobo:
    Gigabyte Z270 Gaming K3
    CPU:
    i3-7320 4.1ghz
    Graphics:
    Gigabyte RX 560 2GB GDDR5
    Mac:
    iMac, Mac mini
    Classic Mac:
    eMac, iBook
    Mobile Phone:
    iOS
    Apr 24, 2017 at 9:58 AM #32
    UtterDisbelief

    UtterDisbelief

    Joined:
    Feb 13, 2012
    Messages:
    878
    Mobo:
    Gigabyte Z270 Gaming K3
    CPU:
    i3-7320 4.1ghz
    Graphics:
    Gigabyte RX 560 2GB GDDR5
    Mac:
    iMac, Mac mini
    Classic Mac:
    eMac, iBook
    Mobile Phone:
    iOS
    Just to clarify - and hopefully help ...

    @Quickshooter is correct. If you are having sleep problems with either the Fenvi or ABWB PCIe-based Broadcom cards you really *do* need to check the motherboard USB header and assign it the correct type. There is a way to do this in:

    Ammulder's Skylake guide. Section 7.2 Getting it Right

    This involves creating a USB SSDT that goes in your EFI/CLOVER/ACPI/patched folder defining each of the 15 ports you are allowed on a Mac. Yes, most of us get started using the 15-30 Port increase patch because our PC motherboards have so many etc, I did too, but ideally you need to define just 15 with the motherboard header you are using for BT as type "255". This is the setting that stops the BT polling of the O/S from waking your system.

    Another thing I've discovered which breaks previously working Sleep on Gigabyte motherboards is BIOS F20 or later. I downgraded to F4 again and this restored service as normal.

    I'm currently using the AWBW card and it's flawless once set up correctly. I also tried a Fenvi card and it was much the same, though it didn't seem so reliable picking up the 5ghz connection. Both cards' performance and connectivity improves if you use better/larger/extended antennas than the ones supplied.

    :)
     
    Quickshooter likes this.
  3. vin047

    vin047

    Joined:
    Jan 18, 2017
    Messages:
    5
    Apr 24, 2017 at 3:14 PM #33
    vin047

    vin047

    Joined:
    Jan 18, 2017
    Messages:
    5
    @UtterDisbelief I think the issue for @southlegend and I is that we've already done the steps to ensure the correct USB header is set to 255, aka internal. (In my case, my X58 mobo doesn't have USB 3, and the system already recognises that it's an internal USB - giving it the 255 value). Despite that, the ABWB card kept waking the system as soon as it went to sleep. Changing to the Fenvi card resolved the issue for me and system stays asleep.

    To clarify (mainly for @southlegend), my remaining sleep issues is the repeating wakeup for 1 minute every 2 hours, which after 7 cycles, causes system to hang. This could be due to the wifi card or something else.
     
  4. UtterDisbelief

    UtterDisbelief

    Joined:
    Feb 13, 2012
    Messages:
    878
    Mobo:
    Gigabyte Z270 Gaming K3
    CPU:
    i3-7320 4.1ghz
    Graphics:
    Gigabyte RX 560 2GB GDDR5
    Mac:
    iMac, Mac mini
    Classic Mac:
    eMac, iBook
    Mobile Phone:
    iOS
    Apr 24, 2017 at 7:50 PM #34
    UtterDisbelief

    UtterDisbelief

    Joined:
    Feb 13, 2012
    Messages:
    878
    Mobo:
    Gigabyte Z270 Gaming K3
    CPU:
    i3-7320 4.1ghz
    Graphics:
    Gigabyte RX 560 2GB GDDR5
    Mac:
    iMac, Mac mini
    Classic Mac:
    eMac, iBook
    Mobile Phone:
    iOS
    OK, I understand. Sorry if I was preaching to the converted! :)

    Strikes me though that there isn't much about the hardware that might cause a problem other than the bluetooth m/b connector because the ABWB is really just genuine Apple kit.

    Having said all that I've just taken a look at the ASRock X58 Deluxe and it's a mighty motherboard - 4x PCIe graphics cards and 6x memory slots! Very impressive I must say. Perhaps there's some quirk in it's Network chip or those PCIe slots. Waking for just 1-minute every two hours seems like it's a "planned" occurrence. No reason wi-fi would do that unless told to by software...

    To troubleshoot you could boot in safe mode, or using the UniBeast stick, and see if the problem still occurs ?

    :)
     
  5. P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    12,157
    Mobo:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    GeForce GT 740 2047 MB
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Apr 24, 2017 at 7:55 PM #35
    P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    12,157
    Mobo:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    GeForce GT 740 2047 MB
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    This struck a chord, I remember an old post about this a while ago and I made a note of it at the time.

    The solution back then was :
    Date & Time > Disable/Uncheck: Set date and time automatically
    Time Zone > Disable/Uncheck: Set time zone automatically using current location

    YMMV
     
    UtterDisbelief likes this.
  6. krispartyka

    krispartyka

    Joined:
    Apr 13, 2017
    Messages:
    15
    Mobo:
    z270x gaming 5
    CPU:
    i7 7700k
    Graphics:
    Aorus GTX 1080 ti
    Jul 7, 2017 at 10:25 PM #36
    krispartyka

    krispartyka

    Joined:
    Apr 13, 2017
    Messages:
    15
    Mobo:
    z270x gaming 5
    CPU:
    i7 7700k
    Graphics:
    Aorus GTX 1080 ti
    I have also got the BCM943602CS and exactly the same problem you are trying to solve it here but I got (sort of) a workaround for it .As mentioned above, it is indeed a problem with the bluetooth m/b connector on that card. I don't know if everyone noticed that the card stays on (in my case small greed led light) even after you have shut down the system all together. It seemed a bit fishy for me so what I did was to unplug the usb power cable from the card and reboot the system again . The wifi module was still up and running but bluetooth was disabled. Only once you have disabled the bluetooth from power source you rig will finally sleep in peace. My workaround for it was to simply buy a separate usb bluetooth card and just stick it in one of the usb ports at the back. Although it works out of the box, I would still wish to get the bluetooth working on that card. I hope this helps somehow....
     
    markusberger83 likes this.
  7. SirDaniel94

    SirDaniel94

    Joined:
    Dec 27, 2016
    Messages:
    80
    Mobo:
    ASUS Z170 Pro Gaming
    CPU:
    Intel Core i7 6700K (Skylake)
    Graphics:
    ASUS Geforce GTX 1070 Strix
    Mac:
    iMac
    Oct 5, 2017 at 5:54 PM #37
    SirDaniel94

    SirDaniel94

    Joined:
    Dec 27, 2016
    Messages:
    80
    Mobo:
    ASUS Z170 Pro Gaming
    CPU:
    Intel Core i7 6700K (Skylake)
    Graphics:
    ASUS Geforce GTX 1070 Strix
    Mac:
    iMac
    i found out that my internal USB is HS10 and i have put everything from 3 to 255 at HS10, but my Mac is still always restarting immediately after sending him to sleep :/
    Any idea?
     
  8. baja-king

    baja-king

    Joined:
    Nov 15, 2011
    Messages:
    56
    Mobo:
    GA-Z77X-UD5H
    CPU:
    I7 3770k @ 4.6 OC
    Graphics:
    GTX 1080
    Mac:
    MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Oct 7, 2017 at 10:00 PM #38
    baja-king

    baja-king

    Joined:
    Nov 15, 2011
    Messages:
    56
    Mobo:
    GA-Z77X-UD5H
    CPU:
    I7 3770k @ 4.6 OC
    Graphics:
    GTX 1080
    Mac:
    MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Hi, I have the same problem - same card.

    Sleep worked fine before and still does if I disconnect the usb from the internal card.

    I have tried to make port HP17 internal using a SSDT but with no luck :banghead:

    How do I see if the port is now internal with IOReg?

    Thanks in advance.


     

    Attached Files:

  9. Quickshooter

    Quickshooter

    Joined:
    May 11, 2013
    Messages:
    179
    Mobo:
    GA-Z170x-UD5-TH
    CPU:
    i7-6700k
    Graphics:
    MSI GeForce GTX 1080Ti Gaming X
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Oct 7, 2017 at 10:08 PM #39
    Quickshooter

    Quickshooter

    Joined:
    May 11, 2013
    Messages:
    179
    Mobo:
    GA-Z170x-UD5-TH
    CPU:
    i7-6700k
    Graphics:
    MSI GeForce GTX 1080Ti Gaming X
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    I've uploaded two screenshots - of your dsl file that I opened with Maciasl and a screenshot of my ioreg with my HS09 port seen as 0xff
    USBConnector 255 would look like 0xff in ioreg and would label this port as 'internal'
     

    Attached Files:

    • ioregscreenshot.jpg  (119.1 KB, 29 views)
    • maciaslscreenshot.jpg  (42.3 KB, 23 views)
  10. baja-king

    baja-king

    Joined:
    Nov 15, 2011
    Messages:
    56
    Mobo:
    GA-Z77X-UD5H
    CPU:
    I7 3770k @ 4.6 OC
    Graphics:
    GTX 1080
    Mac:
    MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Oct 7, 2017 at 10:19 PM #40
    baja-king

    baja-king

    Joined:
    Nov 15, 2011
    Messages:
    56
    Mobo:
    GA-Z77X-UD5H
    CPU:
    I7 3770k @ 4.6 OC
    Graphics:
    GTX 1080
    Mac:
    MacBook Pro, Mac Pro
    Mobile Phone:
    iOS

Share This Page