Contribute
Register

A solution of ASUS new bios ver.2012 (not downgrading)

Joined
Apr 17, 2019
Messages
6
Motherboard
Asus H310T-Clover
CPU
i5-8400
Graphics
UHD 630, 1920x1080
Mobile Phone
iOS
@artroeb I am still figuring out the proper EFI, but at least I have managed to complete the installation (the display resolution is 1280x1024 and audio does not work).
 
Joined
May 4, 2016
Messages
102
Motherboard
Asus Strix B360-I
CPU
i5-9400F
Graphics
GTX 760
Mac
MacBook
Mobile Phone
Android
@artroeb I am still figuring out the proper EFI, but at least I have managed to complete the installation (the display resolution is 1280x1024 and audio does not work).
Dont worry, just add my kext to get audio work. Please share your EFI...

And how about HWMonitor, are temperature is OK?
 
Joined
Apr 17, 2019
Messages
6
Motherboard
Asus H310T-Clover
CPU
i5-8400
Graphics
UHD 630, 1920x1080
Mobile Phone
iOS
CPU temperature when idle is in range of 31-35 C, and jumps to 45-67 C once I open any application (e.g. picture previewer with the screenshot)
 
Joined
May 4, 2016
Messages
102
Motherboard
Asus Strix B360-I
CPU
i5-9400F
Graphics
GTX 760
Mac
MacBook
Mobile Phone
Android
In my EFI On HWMonitor and Intel Power Gadget I got 40-45°C Idle system when I use FakeSMS plugins (kext). And always up when I open app.

When I remove FakeSMC plugins (kext) in idle I got 28-35°C on intel power gadget.

I don't know my EFI is wrong or my Bios setting is wrong.
 
Joined
May 4, 2016
Messages
102
Motherboard
Asus Strix B360-I
CPU
i5-9400F
Graphics
GTX 760
Mac
MacBook
Mobile Phone
Android
Well, it gets hot quickly under load (I only opened a picture previewer), see the attached screenshot.

I thank you. I see your kext you only use 2 plugins. I tried one by one and I found an error reading when I added FakeSMC_LPCSensors.kext I thought I would find out why every time I read the temperature voltage was always an error. Do you have ideas for this?


Screen Shot 2019-04-18 at 6.55.55 PM.png
Screen Shot 2019-04-18 at 7.02.28 PM.png
 
Joined
Aug 18, 2014
Messages
50
Motherboard
Asus X99 PRO USB 3.1
CPU
i7 6800K
Graphics
PNY Nvidia Quadro M6000
Mac
Mac Pro
The extent of my dealings with ASUS support made it pretty clear that once in this new BIOS, it is impossible to downgrade. Maybe they will fix this in a future BIOS update. I don't know why you'd need to downgrade anyway since with this fix this BIOS works perfectly.
For sure, many thanks for the solution! I'm having Issues with Quicksync with this setup. I Managed to make it work right but suddenly I cannot longer open Final Cut... And nothing has changed. Guess is Lilu+Whatevergreen managing things...
 
Joined
Dec 30, 2018
Messages
35
Motherboard
ASRock Z390 Taichi BIOS v1.2
CPU
i7-9700K
Graphics
RX 580
ASUS Rog Strix Z390-i didn't have that option in the latest bios though. Search showed "RTC wake schedule" or something. So the solution wasn't for all motherboards. That's when I got frustrated and gave up. I know people are using hackintoshes on those boards so it can be fixed. I just don't know how. It was pretty board!
I was able to downgrade my ASRock Z390's system's BIOS from version 4.0 to 1.2 by using the windows BIOS update mechanism. I did not expect it to work because ASRock warn you you cannot downgrade and because the processors microcode was upgraded with BIOS 4.0 I did not have much hope for it but as I bought my board specifically for a Hackintosh, I tried it anyway. Once I got back to BIOS version 1.2 everything worked again with no other changes.
 
Top