Contribute
Register

8700k + RX 580 + Asus Z370

Status
Not open for further replies.
Joined
Oct 23, 2011
Messages
235
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
you do not need quicksync in mojave to get hardware encoding/decoding with the rx580 since it is official supported. ;)

Since all the iMac and MBP that use it also have an iGPU active in connector-less mode, yes you need it :)

Just post your result and will se if you have hardware acceleration.
I posted a discussion that have several months and it's very active; why should we try to implement something we don't need?
 
Joined
Apr 12, 2018
Messages
43
Motherboard
Asus Z370-I ROG Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey guys neither of your solutions worked :/

Michelinu: the SSDT; its required right? I have included that in the ACPI patched folder. It didn't work however.

Markmac: I tried yours while disabling the iGPU. It still didn't work :/

EDIT: I get the same error messages
 
Last edited:
Joined
Jun 10, 2018
Messages
14
Motherboard
ASUS ROG Maximus X Hero Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Since all the iMac and MBP that use it also have an iGPU active in connector-less mode, yes you need it :)

Just post your result and will se if you have hardware acceleration.
I posted a discussion that have several months and it's very active; why should we try to implement something we don't need?
From my experience, iGPU with a connector-less framebuffer is needed in 10.13, but when I upgraded to 10.14, my RX580 works fine with all hardware acceleration and iGPU disabled.
 
Joined
Apr 12, 2018
Messages
43
Motherboard
Asus Z370-I ROG Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
From my experience, iGPU with a connector-less framebuffer is needed in 10.13, but when I upgraded to 10.14, my RX580 works fine with all hardware acceleration and iGPU disabled.
I am trying to install High Sierra now and try to get acceleration working there. Then upgrade to Mojave. Right now I'm stuck on even installing High Sierra lol
 
Joined
Jul 13, 2016
Messages
2,923
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
AMD RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Since all the iMac and MBP that use it also have an iGPU active in connector-less mode, yes you need it :)

Just post your result and will se if you have hardware acceleration.
I posted a discussion that have several months and it's very active; why should we try to implement something we don't need?


Right but you realize that the PRO's do not have an IGPU obviously it has to work without it other wise it would not hit their target audience. Anyways here is some proff for you.
 

Attachments

  • No IGPU:QS.jpg
    No IGPU:QS.jpg
    298.9 KB · Views: 115
Joined
Jul 13, 2016
Messages
2,923
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
AMD RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
Joined
Oct 23, 2011
Messages
235
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Right but you realize that the PRO's do not have an IGPU obviously it has to work without it other wise it would not hit their target audience. Anyways here is some proff for you.

The iMac Pro have a Vega GPU, not an RX580.
They're different GPUs.
 
Joined
Oct 23, 2011
Messages
235
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys neither of your solutions worked :/

Michelinu: the SSDT; its required right? I have included that in the ACPI patched folder. It didn't work however.

Markmac: I tried yours while disabling the iGPU. It still didn't work :/

EDIT: I get the same error messages

Post again debug while using my solution. The iGPU MUST be enabled.
 
Joined
Jul 13, 2016
Messages
2,923
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
AMD RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
The iMac Pro have a Vega GPU, not an RX580.
They're different GPUs.

Are you trying to infer that the 580 is incapable of hardware encoding?

PS Mac Pro 6,1 does not have a Vega and pretty sure that is the SM Markmac is using.
 
Status
Not open for further replies.
Top