Contribute
Register

6700k Asus z170-pro d3 - Audio Not Working After CUDA

Joined
Oct 13, 2015
Messages
3
Motherboard
gigabyte ga-z97x-ud3h
CPU
4790k
Graphics
EVGA GTX 970
Mac
Classic Mac
Mobile Phone
Hi guys,

I'm a happy owner of a Hackintosh for one year now and I'm trying to install Mac OS on a friend's computer.
The specs aren't the same and that's the issue. (I've added the config.plist file to this post)

The build:
-6700k
-Asus z170-pro d3
-Asus GTX 980Ti
-Gskill 32GB ram (4x8GB)
-EVO 250GB for OS and Apps
-2x 1tb HDD in raid0



So, here's what I've done so far:

1- Create Mac OS Sierra installer through Unibeast

2- Bios Settings:
-Extreme Tweeker
--AI Overclocker Tuner > X.M.P.
--Extreme Tweeking > Enable
-Advanced Items
--System Agent (SA) Configuration > VT-d > Disable
--PCH Configuration > IOAPIC 24-119 > Disabled
--USB Configuration > Legacy USB Support > Auto
--USB Configuration > XHCI Hand Off > Enabled
--APM Configuration > Power on by PCI - E/PCI > Disabled
-Boot Menu
--Fast Boot > Disabled
--Boot Logo Display > Disabled
--Secure Boot > OS Type > Other OS
--Boot Option 1 > USB installer thumb drive (the UEFI choice if there are two entries)


3 - Boot with the Usb stick containing Mac OS Sierra

4 - Install the OS

5 - Boot into the OS (SSD)

6 - Run Multibeast and install the following drivers:

Quick Start — UEFI Boot Mode
Audio — ALC892
Disk — 3rd Party Data
Misc — Fake SMC Plugins v6.21-311-g2958f55.1723
— FakeSMC HWMonitor Application v6.21-311-g2958f55.1723
Network — IntelMausiEthernet v2.1.0
USB — Increase Max Port Limit


7 - Run CustoMacEssentials to make ethernet work (I don't know why. Just tested it and it worked)

8 - Install Nvidia Web Drivers

9 - Open the Config.plist file with the TextEdit and change the "false" under NvidiaWeb to "true".
<key>NvidiaWeb</key>
<true/>


At this point I had three issues:
-No sound (no devices detected)
-The graphics card didn't perform as it should be on the Cinebench. 98fps vs 112fps on my gtx970. I assumed this is an issue with the SMBIOS but I was going to try to fix this later. Help in this point is highly appreciated.
-No USB 3 (haven't tried to fix it yet but I think it will be simple)


I figured out a way to make the sound work through millions of tests but I assume it isn't the right way.
I did this:

1 - Installed AppleALC.Kext through Kext Utility
2 - Copied AppleALC.kext to /VOLUMES/EFI/EFI/Clover/Kexts/Other
3 - Installed HDAEnabler1.kext through Kext Utility

4 - Reboot

5 - Sound working!

Next thing I did was install the Cuda drivers so I could benefit from The Cud acceleration inside premiere pro, after effects, davinci resolve, etc.

Reboot....

No sound again.

And this is where I'm stuck.
I tried to do a clean install but when I get to this point the same happens.

Do anyone knows what might be causing this? Maybe there's another way to make the sound work?

Thank you for your help and patience.
 

Attachments

Top