Contribute
Register

5K Resolution (5120x2880) via NVIDIA Drivers on Dell UltraSharp 27" Monitor

Joined
May 26, 2010
Messages
74
Motherboard
G5 case Gigabyte GA-Z97MX-Gaming 5
CPU
i7 4770 32GB DDR3 RAM 1066
Graphics
EVGA GTX 980 TI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Thanks cccip! I made those changes in the bios and now my 4k monitor can make it through booting without being turned off but the 5k can't. When I have both on during boot I get a reboot cycle. Still no luck with sleep either but I noticed that sleep does work if the 5k is not yet using the span mode (before power cycling) but once I power cycle, the computer crashes on sleeping. Log says Basic SleepProxy Sleep Proxy Server is not enabled. Basic SleepProxy Could not get the primary interface.
 
Joined
Jan 8, 2012
Messages
86
Motherboard
Z68-UD3H-B3 (U1L UEFI, clover)
CPU
i5-2500K @ 4.0 GHz
Graphics
gigabyte GTX 970
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
I received my up2715k in the mail today and it is working at 5k with hiDPI available following the instructions provided. I am also running a p2715q 4k off of the GTX 980. One thing differed for me - I have to start up my computer with both monitors off, then wait till I have given sufficient time to get to desktop. Then I turn both monitors on and voila! Beauty! One other thing is that upon trying to sleep my monitors go black but the computer never sleeps. If I try to click mouse to wake them nothing happens. Not sure if the computer is crashed or what. Must try to remote in. Ill post more if I find solutions or if you have solutions, please let me know.
Hi dudenesspa, so the 4K p2715q works at 4K60Hz in 10.10.2 with latest nvidia drivers ? How did you have to configure your hack for this (smbios, etc...) ?
 
Joined
May 26, 2010
Messages
74
Motherboard
G5 case Gigabyte GA-Z97MX-Gaming 5
CPU
i7 4770 32GB DDR3 RAM 1066
Graphics
EVGA GTX 980 TI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Hi dudenesspa, so the 4K p2715q works at 4K60Hz in 10.10.2 with latest nvidia drivers ? How did you have to configure your hack for this (smbios, etc...) ?
This was pretty much working OOB with MacPro6, 1 smbios. Additionally, changing the settings in my bios to windows8 and CSM:never as mentioned previously, allowed me to boot without having to turn the monitor off during boot. I am imagining and hoping nvidia web drivers will continue to improve support for 4k and 5k. 4k monitor sleeps normally as well. Can't say that about 5k.

I also confirmed with author of Barefeats article that he did not have sleep working with 5k monitor. He said he will follow up with NVidia to ask if they are working on a fix for this sleep issue.
 
Joined
Dec 14, 2011
Messages
78
Motherboard
Asus ROG Striz Z390-I Gaming
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hi, I have Dell UP2715k and a 980 gtx but I wasn't able to obtain the 5K.
I use clover with imac 14,2 definition, 10.10.2 installed and 343.02.02.f02 nvidia alternate driver, I added the magic code nv_spanmodepolicy=1 to the boot-args (together with dart=0 nvda_drv=1 kext-dev-mode=1) but when I start up the monitor is a regular 2560x1440, if I shut it down and power up I see just half of the screen and the monitor menu (on the monitor not on OSX) says that I'm using 2560x2880 (the image is heavily distorted as reported below). I'm obviously using both the displayport cable, one attached to the first displayport of the card and the other to the second (the first is the closer to the PCI-e connector), the 980 is the asus strix one.

 
Joined
May 26, 2010
Messages
74
Motherboard
G5 case Gigabyte GA-Z97MX-Gaming 5
CPU
i7 4770 32GB DDR3 RAM 1066
Graphics
EVGA GTX 980 TI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
This happened to me a couple times. I would actually pull the power cord out of the back of the monitor and plug it back in. I'd also double check to make sure the web driver is actually being used. Finally, perhaps you need to try a different device smbios for Mac Pro rather than iMac.
 
Joined
Dec 14, 2011
Messages
78
Motherboard
Asus ROG Striz Z390-I Gaming
CPU
i5-9600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
This happened to me a couple times. I would actually pull the power cord out of the back of the monitor and plug it back in. I'd also double check to make sure the web driver is actually being used. Finally, perhaps you need to try a different device smbios for Mac Pro rather than iMac.
now it works and I haven't change anything, simply starting the monitor when osx is already booted, I have already tried it but every time I try after a freeze (when I start osx with monitor ON and the power cycle the monitor osx freeze), after manual rebooting it doesn't work. What a strange behavior
 
Joined
May 26, 2010
Messages
74
Motherboard
G5 case Gigabyte GA-Z97MX-Gaming 5
CPU
i7 4770 32GB DDR3 RAM 1066
Graphics
EVGA GTX 980 TI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Great news! It's a great monitor I love it more and more everyday. Just hope nvidia doesn't leave this piece of the drivers half baked. I agree it acts strange at times.
 
Joined
May 26, 2010
Messages
74
Motherboard
G5 case Gigabyte GA-Z97MX-Gaming 5
CPU
i7 4770 32GB DDR3 RAM 1066
Graphics
EVGA GTX 980 TI
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Just curious if you can get 5k resolution with an AMD card. Looking to the future.
 
Joined
Oct 30, 2015
Messages
2
Mac
Classic Mac
Mobile Phone
Awesome dude!

Got it working on Capitan 10.11.1

gtx 970 g1 gaming

and LG 31mu97-b

Gettin stupid by seeing how sharp it's now!

Cheers!
 
Joined
Jan 13, 2015
Messages
1
Motherboard
Gigabyte X99 UD4
CPU
i7-5820K @ 4,4Ghz
Graphics
MSI GTX 980Ti Gaming 6G
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
5K.png

10.10.5 + NVIDIA Web Driver 346.02.03f05 + 2xDP1.2 + aforementioned boot flags + power cycle = 5K :headbang:
 
Top