Contribute
Register

4530s won't boot from EFI Partition, only USB. Clover doesn't exist on Drive.

Joined
Jun 11, 2014
Messages
13
Motherboard
HP Probook 4530s
CPU
Dual Core 2nd Gen Intel Core i3
Graphics
Intel 3000 intergrated graphics
Mac
Classic Mac
Mobile Phone
Android
I am having issues with getting my 4530s to boot without the need for the USB. The installation process went flawlessly, but even after using the probook installer for Yosemite, and using the clover installer, it still won't boot. The EFI partition is visible as I have shown hidden partitions enabled from the debug menu of disk utility. I have tried with the EFI partition mounted and unmounted. When I try to boot from the ssd alone, I get a version of clover with a simple grey background, and the clover logo at the top, but it doesn't boot the drive. When I boot from the EFI on the usb, I am greeted with another version of Clover, this time with a much nicer look (Blurred standard Yosemite wallpaper, and large circular buttons with X's on).

Has anyone else had this issue?

Many thanks,

Michael.
 
Joined
Oct 22, 2012
Messages
3,476
Motherboard
HP Elitebook 8470p
CPU
Intel Core i5 3320M
Graphics
Intel HD 4000, 1600x900
Mobile Phone
iOS
I am having issues with getting my 4530s to boot without the need for the USB. The installation process went flawlessly, but even after using the probook installer for Yosemite, and using the clover installer, it still won't boot. The EFI partition is visible as I have shown hidden partitions enabled from the debug menu of disk utility. I have tried with the EFI partition mounted and unmounted. When I try to boot from the ssd alone, I get a version of clover with a simple grey background, and the clover logo at the top, but it doesn't boot the drive. When I boot from the EFI on the usb, I am greeted with another version of Clover, this time with a much nicer look (Blurred standard Yosemite wallpaper, and large circular buttons with X's on).

Has anyone else had this issue?

Many thanks,

Michael.
Go to terminal and type diskutil list. Post result here.
 
Joined
Jun 11, 2014
Messages
13
Motherboard
HP Probook 4530s
CPU
Dual Core 2nd Gen Intel Core i3
Graphics
Intel 3000 intergrated graphics
Mac
Classic Mac
Mobile Phone
Android
Thanks for the quick reply

Sorry, I just took a screenshot, but here's the actual text:

#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *120.0 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_HFS Yosemite 119.2 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *1.0 TB disk1
1: EFI EFI 209.7 MB disk1s1
2: Apple_HFS HackBook 997.9 GB disk1s2
Michaels-MacBook-Pro:~ Miguel$

 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I am having issues with getting my 4530s to boot without the need for the USB. The installation process went flawlessly, but even after using the probook installer for Yosemite, and using the clover installer, it still won't boot. The EFI partition is visible as I have shown hidden partitions enabled from the debug menu of disk utility. I have tried with the EFI partition mounted and unmounted. When I try to boot from the ssd alone, I get a version of clover with a simple grey background, and the clover logo at the top, but it doesn't boot the drive. When I boot from the EFI on the usb, I am greeted with another version of Clover, this time with a much nicer look (Blurred standard Yosemite wallpaper, and large circular buttons with X's on).

Has anyone else had this issue?

Many thanks,

Michael.
Post EFI/Clover folder on the HDD.
 
Joined
Jun 11, 2014
Messages
13
Motherboard
HP Probook 4530s
CPU
Dual Core 2nd Gen Intel Core i3
Graphics
Intel 3000 intergrated graphics
Mac
Classic Mac
Mobile Phone
Android
I can't compress the folder because I get this error:

An error occurred while adding “Firmware.scap” to the archive.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I can't compress the folder because I get this error:

An error occurred while adding “Firmware.scap” to the archive.
Read carefully. The request was for the EFI/Clover folder, not the entire EFI folder.
 
Joined
Jun 11, 2014
Messages
13
Motherboard
HP Probook 4530s
CPU
Dual Core 2nd Gen Intel Core i3
Graphics
Intel 3000 intergrated graphics
Mac
Classic Mac
Mobile Phone
Android
Here you go. Thanks :)
 

Attachments

Joined
Jun 11, 2014
Messages
13
Motherboard
HP Probook 4530s
CPU
Dual Core 2nd Gen Intel Core i3
Graphics
Intel 3000 intergrated graphics
Mac
Classic Mac
Mobile Phone
Android
Where did I go wrong? I'm 100% sure I followed it correctly. I must be doing something correctly, if I'm able to boot to a fully working OS X from the USB though, right?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Where did I go wrong? I'm 100% sure I followed it correctly. I must be doing something correctly, if I'm able to boot to a fully working OS X from the USB though, right?
You need to use the ProBook installer as detailed in the guide.

Your EFI/Clover lacks the correct config.plist, has incorrect drivers in Clover/kexts/10.10, and has no patched ACPI files in ACPI/patched.
 
Top