Contribute
Register

.

Status
Not open for further replies.

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
All kext files moved off /E/C/K/O and into /L/E;
kext cache confirmed recreated;
System restarted;
Clover ACPI and other log files recreated fresh;
No improvements with the background slider or function keys;
New dump generated and attached to this post;
drivers/UEFI folder seems to have too many files in there

.dsl files do not belong in acpi/patched folder

have you tried to disable these:
Code:
<key>EDID</key>
        <dict>
            <key>Custom</key>
            <data>
            AP///////wAGEPKcAAAAABoVAQSVGg54Au8Fl1dUkiciUFQAAAAB
            AQEBAQEBAQEBAQEBAQEBFDeAuHA4JEAQED4ANa4QAAAaECyAuHA4
            JEAQED4ANa4QAAAaAAAA/ABDb2xvciBMQ0QKICAgAAAA/QA4TB5T
            EQAKICAgICAgACg=
            </data>
            <key>Inject</key>
            <true/>
            <key>ProductID</key>
            <string>0x9C7C</string>

also this:

Code:
<key>ig-platform-id</key>
        <string>0x19160000</string>

should be:

Code:
<key>#ig-platform-id</key>
        <string>0x19160000</string>

as you are getting the properties from:

Code:
<key>AAPL,ig-platform-id</key>
                <data>
                AAAWGQ==
                </data>

0x191b0000 maybe a better choice

these should be enabled:
Code:
<key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixLAN</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixTMR</key>
                <false/>

also for brightness controls:
maybe check this:

and

 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Clover installs them without the -64 naming, whereas Clover Configurator uses the -64 naming. Cleaned.
DSL files on ACPI/patched do no harm since they are ignored by the boot loader. Cleaned.
Removed EDID.
Changed ig-platform-ID key to #ig-platform-ID.
Changed AAPL,ig-platform-id to 0x191b0000.
Enabled HPET, IPIC, LAN, RTC and TMR fixes



Those were the two guides originally followed before the initial post asking for help. Other directions from multiple posts also followed, to no avail. Worth mention the slider used to work on Mojave, but never on Catalina. Keys were never able to be made working. Also, it is my understanding AppleBacklightFixup was incorporated long ago into WEG.

With all suggested changes, still no improvements.
ACPI and preboot log files created fresh.
New debug file generated and attached to this post.
don't you need to patch your DSDT for brightness keys?
hence this link:
for brightness keys

config.plist still shows:
Code:
<key>ProductID</key>
            <string>0x9C7C</string>

and:

Code:
<key>ig-platform-id</key>
        <string>0x19160000</string>

this should also now be removed:

Code:
<key>ForceKextsToLoad</key>
        <array>
            <string>\System\Library\Extensions\IONetworkingFamily.kext</string>
        </array>
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Removed all lingering keys.

I agree function keys to control brightness needs DSDT patching, but if the main brightness controls are not working, having the keys set are less important and not having them right now is one less thing for me to take in account while trying to fix the primary brightness issue. Trying to walk one step at a time before I can run.
i use this way for screen brightness, it may be worth a shot:

Make sure you remove SSDT-PNLF, SSDT-ALS0.
Remove AppleBacklightFixup.kext or if you were using the old AppleBacklightInjector.kext from Rehabman.
Leave only whatevergreen.kext

Into config.plist /Devices/Properties (not inside the IGPU) just on Devices/Properties add the values:
SetIntelBacklight=True (boolean)
SetIntelMaxBacklight=True (boolean)

Enable/add the config.plist /DSDT/Fixes/ AddPNLF=True

Reboot and Brightness should work correctly.

credit @Sniki
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
It was worth a shot, but still no cigar.
try disabling:
Code:
<dict>
                <key>Comment</key>
                <string>change F%uT%04x to F%uTxxxx in AppleBacklightInjector.kext (credit RehabMan)</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                RiV1VCUwNHgA
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>Name</key>
                <string>com.apple.driver.AppleBacklight</string>
                <key>Replace</key>
                <data>
                RiV1VHh4eHgA
                </data>
            </dict>

also I use VirtualSMC instead of FakeSMC, it could be worth giving it a go

 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,695
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Disabled this particular kext patching (shouldn't be doing anything as there was no matching kext but hey, who knows what other binary was being hit?).

VirtualSMC does not work on my laptop - it causes the boot to hung forever (left it overnight and it was stuck with the same output). FakeSMC is the only that works. Should I try OpenCore just because?
with VirtualSMC, you may need LiluFriend.kext

after installing VirtualSMC and related kexts and efi, run create_lilufriend.sh


hit the green download as zip and extract
 
Status
Not open for further replies.
Top