Contribute
Register

11.4 Update Causes Black Screen

Status
Not open for further replies.
Joined
Jun 30, 2021
Messages
3
Motherboard
ROG Strix X570-E Gaming
CPU
AMD Ryzen™ 9 5950X
Graphics
Sapphire HD 7850 2G
Mobile Phone
  1. Android
49-minute update of macOS 11.4 (20F71) for my H61 | 2500K | HD 7850 build with OpenCore 0.6.9
View attachment 520366
Hey Bustycat, thanks for your sharing, I found your comment by searching.

I'm building a macOS 11.4 hackintosh, I use the same Graphics card as yours, but I encounter a black screen issue after `IOConsoleUsers: gIOScreenLock` log, I've tried many solutions but nothing helped. Could you share your EFI files with me? looking for your response :)
 
Joined
Oct 10, 2015
Messages
1,095
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey Bustycat, thanks for your sharing, I found your comment by searching.

I'm building a macOS 11.4 hackintosh, I use the same Graphics card as yours, but I encounter a black screen issue after `IOConsoleUsers: gIOScreenLock` log, I've tried many solutions but nothing helped. Could you share your EFI files with me? looking for your response :)
Nothing special actually. I simply added WEG. Did you also connect to HDMI?
 
Joined
Jun 30, 2021
Messages
3
Motherboard
ROG Strix X570-E Gaming
CPU
AMD Ryzen™ 9 5950X
Graphics
Sapphire HD 7850 2G
Mobile Phone
  1. Android
Nothing special actually. I simply added WEG. Did you also connect to HDMI?
I appreciate getting your response. Yes, I have tried both HDMI and DP ports but didn't help. I also flashed GOP to support UEFI so my bios can turn of CSM. I can launch the installer and select a disk to install, but I encounter the black screen issue during the installation phase after seeing a log "OConsoleUsers: gIOScreenLock".
I see several successful cases that use HD 7850, but both of them use Intel CPU, I'm not sure if this issue is related to AMD when composing with HD 7850.
 
Joined
Oct 10, 2015
Messages
1,095
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
I appreciate getting your response. Yes, I have tried both HDMI and DP ports but didn't help. I also flashed GOP to support UEFI so my bios can turn of CSM. I can launch the installer and select a disk to install, but I encounter the black screen issue during the installation phase after seeing a log "OConsoleUsers: gIOScreenLock".
I see several successful cases that use HD 7850, but both of them use Intel CPU, I'm not sure if this issue is related to AMD when composing with HD 7850.
I didn’t flash mine to GOP as the UEFI support of the H61 motherboard is not mature enough.
 
Joined
Jun 30, 2021
Messages
3
Motherboard
ROG Strix X570-E Gaming
CPU
AMD Ryzen™ 9 5950X
Graphics
Sapphire HD 7850 2G
Mobile Phone
  1. Android
I just replace HD 7850 with RX 570, then everything works...
 
Status
Not open for further replies.
Top