Contribute
Register

11.4 Update Caused OpenCore patch for Intel I225-V 2.5GBe Controller Stopped Working

Joined
Jul 20, 2014
Messages
926
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Lastly I did a Migration (WITHOUT NETWORK SETTING CHECKED) on 11.4's Fresh Install... and it works :thumbup:

Next step : enable the second NIC Intel i225 ;)
EDIT
The second NIC failed to work with the same kernel patch
 
Last edited:
Joined
Nov 4, 2011
Messages
42
Motherboard
Gigabyte Z490 Vision D-F5
CPU
i9-10900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Solution that worked for me:

1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
3. add "dk.e1000=0" (without quotes) to boot-args.
 
Last edited:
Joined
May 11, 2011
Messages
2,265
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Solution that worked for me:

1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
3. add "dk.e1000=0" (without quotes) to boot-args.
THAT fixed it for me...and my I-225V is working again!
 
Joined
Jun 10, 2021
Messages
258
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Solution that worked for me:

1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
3. add "dk.e1000=0" (without quotes) to boot-args.
Thanks, I tried this in Monterey and it seems to work, also no more system crashing so far. Any good ideas to get wifi working in Monterey?
 
Joined
May 11, 2011
Messages
2,265
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Thanks, I tried this in Monterey and it seems to work, also no more system crashing so far. Any good ideas to get wifi working in Monterey?
Have you tried enabling airportbrcmfixup and itlwm.kext together?
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,266
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Solution that worked for me:

1. Disable FakePCIID.kext and FakePCDID_Intel_i225-V.kext in config.plist,
2. remove everything concerning i225 in DeviceProperties/Add/PciRoot...
3. add "dk.e1000=0" (without quotes) to boot-args.
Worked for me on an Asus B550 board I have, nice find.
 
Joined
Jun 10, 2021
Messages
258
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Have you tried enabling airportbrcmfixup and itlwm.kext together?
Tried that as well with a multitude of different kext settings, it still stays disabled. Cannot flick the toggle switch to turn it on.
 
Joined
May 11, 2011
Messages
2,265
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Tried that as well with a multitude of different kext settings, it still stays disabled. Cannot flick the toggle switch to turn it on.
You need to download the Heliport app to run that you know. The three work in tandem.
 
Joined
Jun 10, 2021
Messages
258
Motherboard
Gigabyte Z690 Aero G
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
You need to download the Heliport app to run that you know. The three work in tandem.
Got that and tried it too, Heliport icon will show the wifi but not the actual pc wifi. Although Heliport shows wifi and connects there is no wifi because if I turn of ethernet port there is no more internet.
Screen Shot 2021-07-06 at 3.41.28 PM.png
 
Joined
May 11, 2011
Messages
2,265
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Got that and tried it too, Heliport icon will show the wifi but not the actual pc wifi. Although Heliport shows wifi and connects there is no wifi because if I turn of ethernet port there is no more internet.
View attachment 523821
Have you also removed the PCI device properties for the Intel I-225V? And did you add the dk.e1000=0 into the boot-arg? Also try using new versions of Airportbrcmfixup and itlwm.
 
Top