Contribute
Register

10.8.5 - Asus p8z77-m - problems to get it working

Status
Not open for further replies.
Joined
Sep 1, 2013
Messages
1
Mac
Classic Mac
Mobile Phone
Hardware
CPU: i7-3770k @3,5 GHz
GPU: AMD Sapphire HD Radeon 7770 GHz Edition
Mainboard: Asus p8z77-m (not the pro version!)
RAM: 16 GB (4x 4GB)
1x SSD 120GB used for windows
2x TB drives for my data (contains data from the usage with windwows)
1x SSD 60GB for the OSX installation



Hey guys I hope this great community can help me :)

As you can read in the title I´ve problems to get ML 10.8.5. running correctly onto my Asus p8z77-m board. I´ve tried methods/DSDTs from this
thread but it dont wants to work. I´ve read and watched a lot of how to build a Hackintosh and how solving issues but this is still my first Hackintosh so please explain steps in detail for me (noob alert).
Later I also want to use my graphiccard and the other harddrives for my data, but the first/main point is it to get it running correctly.


This is the way how I´ve tried it


Before I started I removed 3 RAM-Sticks and only let one inside (each 4 GB) for the installation to avoid issues.
I updatet my BIOS to the newest version (2105) right from the
official website (because I didn´t find a working flashed/patched one for this board).
I set up my BIOS with recommended settings like changing SATA to AHCI mode or only using the iGPU (I´ve read it´s better to post install this GPU).

On a borrowed MacBook-Air I´ve created a Mounntion Lion 10.8.5 bootstick using unibeast and a 64GB USB 3.0 stick.

I removed any USB devices exepcting wired mouse / tastatur and the network cable from my PC.

I succesfully got through the installer without using any bootflags. I started by opening the Disk Utilities and formating my empty 60GB SSD to the "Mac OS Extended (Journaled)" format (I named it OSX). All of my other harddrives were listed in the Disk Utilities.
After the installation was finished I had to reboot. I rebooted and on the bootstick I selected my 60GB SSD OSX Drive, but all I saw was the screen with the apple Logo and the spinning wheel. I used the bootflag "-x" to get to the secound part of the installation.
I successfully got into ML. I couldn´t plug in annother USB-sticks it only recognises drives which are formated in the mac format.

My internert worked so I downloaded MultiBeast for ML and other stuff. I ran MultiBeast and used the EasyBeast method.
I restart from the menue in OSX. A dark grey screen apperaed and then the PC rebootet and automaticly load my OSX Drive but at the bootscreen with the apple logo it stuck. The same by using bootflasgs like "-x", "GraphicsEnabler=No" or "PCIRootUID=1".
I researched a lot of time and found the boot flag "-x -v -f apci=off cpus=1 PCIRootUID=1 busratio=20" which worked for me (
here GERMAN!).
The USB 3.0 ports are working now but there for the internet is disabeld and it still doesn´t recognizes other usb-drives.
I ran MultiBeast again and chose DSDT-Free installation... no succes.

So I´ve ran to whole installation setup of OSX with exact the same steps again. And downloaded differnet DSDTs from this
thread I´ve mentioned at the beginng. But I can´t follow how do they get it working. I used one DSDT of this thread with Multibeast but after a reboot OSX won´t boot with any booflag even not with "-x -v -f apci=off cpus=1 PCIRootUID=1 busratio=20".

IMG_5164.jpg

And I´m sorry if I created a unnecessary new thread for this but I need more help than just for this specific board and the knowledge level was little bit to high for me there.

I hope someone can help :)


p.s.: during my tries I got issues with my other harddrives (windows drive and one data drive) suddenly I couldn´t find them in the BIOS and the boot priority was changed automaticly sometimes. I didin´t put the other RAM-sticks back yet.
 

v33

Joined
Aug 5, 2012
Messages
89
Motherboard
ASUS P8Z77-M Pro
CPU
Intel i5 3470 3.2ghz
Graphics
EVGA GTX 650Ti Boost 2GB
Mac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
  2. Other
I have a successful install using an Asus P8Z77-M Pro. The same steps should work with your mobo, except i'm not sure about the Radeon (I have veered away from this brand/model). Also, I have not yet used an SSD and can't help you with those.

Your screen shot shows a timeout happening due to the Power Management issue on Asus boards. You will need to patch your BIOS. Just follow this guide below to get to the PMPatch utility. You need to patch BIOS 2015 from the Asus website and then use the Asus Flashback method. I've tried going through the FTK method by installing the new bios (2015), backing it up, and then patching with PMPatch and flashing ... this method did not work, don't waste your time. Asus Flashback is easier!

http://biosrepo.wordpress.com/2013/01/19/simple-way-to-patch-your-own-bios/


Btw, my Multibeast install also failed at first. I was using 10.8.4 and upgrade using the App Store, I did not get to use the recommended Combo Update installer. After upgrading to 10.8.5, I run Multibeast using DSDT Free, Audio Realtek and the Network drivers... after failing to boot up, I used a 2nd drive with 10.8.4 and removed the Multibeast .plist file in the Extras folder. I then installed Chimera 2.2.1 and booted up successfully. I'm not saying you should follow this as your setup is completely different from mine.

Here are some links that may help you, I've read through all of them and choose the method i describe above and that worked for me.

http://www.tonymacx86.com/mountain-...vi-hdmi-audio-sleep-wake-ethernet-usb3-9.html

http://www.tonymacx86.com/mountain-...sd-ocz-agility-120gb-wd-600gb.html#post565330


DSDT guide for Asus P8Z77-M Pro...
http://www.tonymacx86.com/dsdt/85383-dsdt-asus-p8z77-m-pro.html

I hope you get your hack working. HTH!
 
Status
Not open for further replies.
Top