Contribute
Register

10.6.7 Native ATi 5xxx/6xxx Cards which work (and don't)

Status
Not open for further replies.
Joined
Jan 24, 2011
Messages
96
Mac
Classic Mac
Mobile Phone
mjgunn said:
SUCCESS

Brand=XFX
Model=6870 HD-687A-ZDFC (New twin blade cooler model)
Device ID=0x6738
Multibeast=3.4 & Andy's Fix
MacOS=10.6.7
Reported by=MJGunn

Built my new machine with the XFX, edited the device ID in, and ran cinebench on the new setup. FPS was 33.17 on the old machine, 37.96 on this one.
 

jpa

Joined
Jun 13, 2010
Messages
873
Motherboard
10.8
CPU
i7 930
Graphics
6870
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
haysoos123 said:
Div said:
Has anyone got a HIS to fully work? My friend has the HIS 6870 and we have his mac hackintoshed, but I can't seem to get his updates working fully. Can't open steam etc.

Any issues anyone else try? I find it weird two different brands and one will work than the other. I did the same exact thing for my XFX and it works flawless and his HIS does not.

I have this HIS card, which is the reference design:
http://www.newegg.com/Product/Product.a ... -_-Product

It works about as well as the other reference cards from other brands as far as I know. I'm running SL 10.6.7 Vanilla, patched DSDT, with Andy's modified Chameleon RC5 and MBP driver kexts and GraphicEnabler=yes.

The only reason I can think of where it won't work is if you haven't got the right version of Chameleon installed where you can specify the framebuffers, and are only using the MBP kexts by themselves. It'll work, but you wouldn't be able to launch most steam games or cinebench or DVD player.

My only issue is the way too bright gamma in source steam games, and maybe performance isn't super great (I blame the drivers). I can play any other games on it fine, though.

your cinebech points? novabech
 

x64

Joined
Feb 5, 2011
Messages
14
Motherboard
Asus P6X58D-E
CPU
Intel Core i7-930
Graphics
Nvidia Geforce GTX 460
Mac
Classic Mac
Mobile Phone
Adding to the SUCCESS list:

Brand=ASUS
Model=EAH6870 DC/2DI2S/1GD5
Device ID=0x6738
Multibeast=3.4
MacOS=10.6.7
Reported by=x64

64-bit kernel with GraphicsEnabler=no
 
Joined
Feb 21, 2011
Messages
281
Motherboard
Lenovo ThinkCentre M83
CPU
i5 4670
Graphics
Nvidia gtx 750ti
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Mine is now a working model with 10.6.7 ATI kexts, notice prior to upgrade to sandy bridge i was not able to make it work.

Brand=sapphire
Model=5770 vapor-x
Device ID=0x68b8
Multibeast=No, used andy's guide
MacOS=10.6.7
Reported by=emaf
 
Joined
Aug 12, 2010
Messages
1,586
Motherboard
X58A-UD3R v2
CPU
i7-930
Graphics
5770
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Updated guide

http://www.tonymacx86.com/viewtopic.php?f=15&t=15798

Vanilla install - no need for GraphcisEnabler=Yes - so will work with any Chameleon boot file. Anyone who had been using Andy's boot method - this will work for you too.

DVD Player and Geekbench fixed !!!
 
Joined
Jan 24, 2011
Messages
96
Mac
Classic Mac
Mobile Phone
Thanks for the writeup notshy. What's the advantage to going GY=No over how we have it setup now?
 
Joined
Mar 13, 2011
Messages
116
Motherboard
OS X Mountain Lion
CPU
i7 2600K
Graphics
GTX 680
Mac
Classic Mac
Mobile Phone
ASUS EAH6870 DC/2DI2S/1GD5, how does that seem? Guides? I want this too run without sleep or DVD errors, has anybody experienced that yet?

Are there actually any cards that do run without problems yet?
 
Status
Not open for further replies.
Top