Contribute
Register

10.11.0-10.11.3 Skylake Starter Guide

Status
Not open for further replies.
Joined
May 12, 2012
Messages
43
Motherboard
GA z170x UD5 th
CPU
i7 6700k
Graphics
GTX 770
Mac
  1. Mac Pro
In the end, you should have the following:
  • The APIC patch for the beginning in KextsToPatch in EFI/CLOVER/config.plist
  • The USBInjectAll kext in EFI/CLOVER/kexts/...
  • A SSDT-USB.aml in EFI/CLOVER/ACPI/patched/ to configure the correct ports for your motherboard
  • If you have more than 15 total USB entries in the SSDT, a boot argument to disable some of them so the total is 15 or fewer. This should probably be in Boot/Arguments in EFI/CLOVER/config.plist

Hi,

Thank you for this guide. I made it over here through your 10.11.4+ guide. I am currently running 10.11.6

I've gone through this guide quite extensively for my z17x UD5th.
Did recommended clover patches and kexts.
Mapped USB ports and USB 3.0 ports and created ssdt-usb.
Disabled unused ports bringing total to 14 with boot arguments.
All usb 2.0 are working great. All 14 active ports showing up at expected in ioReg.

Having an issue where the system will only mount (and supply power) to one USB3.0 drive of the 4 I have. Additional drives will not mount or will report "USB NEEDS POWER"

Would welcome any suggestions?
 
Joined
Jan 5, 2013
Messages
1
Motherboard
Asus Z170 Pro Gaming
CPU
4.8 Ghz i5 6600k
Graphics
GeForce GTX 1070
Mac
  1. iMac
Great guide. Thank you
I attached my SSDT_USB files for ASUS Z170i Pro Gaming with 15 USB ports:

HS01: USB2 device on port #1 from USB3 motherboard header, port <01 00 00 00>
HS02: USB2 device on port #2 from USB3 motherboard header, port <02 00 00 00>

HS05: USB2 device on USB3 #1, port <05 00 00 00>
HS06: USB2 device on USB3 #2, port <06 00 00 00>
HS07: USB2 device on USB3 #3, port <07 00 00 00>
HS08: USB2 device on USB3 #4, port <08 00 00 00>

HS09: USB2 #1 from USB2 motherboard header, port <09 00 00 00>
HS10: USB2 #2 from USB2 motherboard header, port <0A 00 00 00>

HS13: USB2 for Bluetooth USB Host Controller, port <0D 00 00 00>

SS01: USB3 #1 from USB3 motherboard header, port <11 00 00 00>
SS02: USB3 #2 from USB3 motherboard header, port <12 00 00 00>

SS05: USB3 #1 from up, port <15 00 00 00>
SS06: USB3 #2 from up, port <16 00 00 00>
SS07: USB3 #3 from up, port <17 00 00 00>
SS08: USB3 #4 from up, port <18 00 00 00>

HS03-HS04: unused
HS11-HS12: unused
HS14: unused
SS03-SS04: unused
SS09-SS10: unused
USR1,USR2: unused
 

Attachments

  • SSDT-USB-Z170i-ProGaming.aml
    697 bytes · Views: 119
  • SSDT-USB-Z170i-ProGaming.dsl
    4.7 KB · Views: 121
Joined
Aug 22, 2016
Messages
284
Motherboard
Gigabyte GA-Z170X-UD5 TH (F22g)
CPU
i7 6700K
Graphics
HD 530
ammulder: Thanks for doing this article. I just got done using it to do my USB ports the right way. :)
 
Joined
Feb 10, 2010
Messages
354
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700K
Graphics
Radon RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
ammulder. Great write up. I'm trying to get my GA-Z170X-UD5 motherboard running on USB "the right way". I am trying to do a as complete as possible Clover only build, without third party kexts. I'm running Sierra 10.12.1, and I know this thread is aimed at El Capitan, but I still want to get the USB.asl built. I've got the port limit raised, and 26 ports are showing up. I can now plug devices into the ports, and they work, but in IORegistryExplorer, I am not getting the "tick" next to the devices when plugged in. Any suggestions?
 
Joined
Feb 10, 2010
Messages
354
Motherboard
Gigabyte GA-Z170X-UD5
CPU
i7-6700K
Graphics
Radon RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
ammulder. Great write up. I'm trying to get my GA-Z170X-UD5 motherboard running on USB "the right way". I am trying to do a as complete as possible Clover only build, without third party kexts. I'm running Sierra 10.12.1, and I know this thread is aimed at El Capitan, but I still want to get the USB.asl built. I've got the port limit raised, and 26 ports are showing up. I can now plug devices into the ports, and they work, but in IORegistryExplorer, I am not getting the "tick" next to the devices when plugged in. Any suggestions?

ammulder, I was finally able to figure this part out. The wedges do not show up on Sierra (from what I've seen), but when you plug in a USB device, the port-status under the port you are viewing will change from 0x0 to 0x1300 or 0x1100, depending on what type of port it is, and probably other variables (type of device, etc). This solves part of my issue.

The other issue I'm having is there are two other ports on the back of my motherboard that don't seem to show up under XHC. I know I've seen a reference, but I just can't find it. The two ports are a USB 3.1 port, and a USB-C port. Any ideas where to look for these, and would the SSDT injection work for these as well?

Thanks!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,698
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Thanks for the awesome guide, ammulder!

Here's my contribution, SSDT-USB files for the Asus Maximus VIII Gene:

HS01: USB2 #1 from USB3 motherboard header 1, port <01 00 00 00>
HS02: USB2 #2 from USB3 motherboard header 1, port <02 00 00 00>
HS03: USB2 #1 below ethernet port, port <03 00 00 00>
HS04: USB2 #2 below ethernet port, port <04 00 00 00>
HS05: USB2 #1 below PS2 port, port <05 00 00 00>
HS06: USB2 #2 below PS2 port, port <06 00 00 00>
HS07: USB2 to right of USB3.1, port <07 00 00 00>
HS08: USB2 to right of USB3.1, port <08 00 00 00>

HS11: USB2 #1 on USB2 motherboard header 2, port <0b 00 00 00>
HS12: USB2 #2 on USB2 motherboard header 2, port<0c 00 00 00>
HS13: USB2 #1 on USB2 motherboard header 3, port <0d 00 00 00>
HS14: USB2 #2 on USB2 motherboard header 3 Internal Bluetooth, port<0e 00 00 00>

SS01: USB3 #1 from USB3 motherboard header 1, port <11 00 00 00>
SS02: USB3 #2 from USB3 motherboard header 1, port <12 00 00 00>
SS03: USB3 #1 below ethernet port, port <13 00 00 00>
SS04: USB3 #2 below ethernet port, port <14 00 00 00>
SS05: USB3 #1 below PS2 port, port <15 00 00 00>
SS06: USB3 #2 below PS2 port, port <16 00 00 00>
SS07: USB3 to right of USB3.1, port <17 00 00 00>
SS08: USB3 to right of USB3.1, port <18 00 00 00>

HS09-HS10: unused
SS09-SS10: unused
USR1,USR2: unused
gene usb ports.jpg
 

Attachments

  • SSDT-USB-Maximus-VIII-Gene.aml
    894 bytes · Views: 239
  • SSDT-USB-Maximus-VIII-Gene.dsl
    5.8 KB · Views: 212
Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,817
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
pastrychef, if one is to use the SSDT in the above post, does one have to not use the MultiBeast USB options? Please elaborate. TIA.
 
Status
Not open for further replies.
Top