Contribute
Register

10.10.3 Update Black screen with cursor

Joined
Jan 4, 2011
Messages
77
Motherboard
Gigabyte Z370 Aorus Gaming 7
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro
Now my Hack shows a Supplemental Update concerning video drivers?! What's up with that? Is it safe or will my 7750 go back to no signal after boot... maybe they fixed it?
 
Joined
Mar 2, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
Jithin.C.V
thx!!!

10.10.1 new install -> 10.10.3 combeupdate -> change kext -> good working!!


when fixed kext copy, old 10.10.3 is not working

result, new 10.10.0 install.. OTL..

 
Joined
May 9, 2011
Messages
5,936
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Gigabyte GTX 970 WINDFORCE / Intel HD Graphics 530
Mac
iMac
Mobile Phone
iOS
when fixed kext copy, old 10.10.3 is not working
result, new 10.10.0 install.. OTL..
What you mean by the above quoted text??
 
Joined
Oct 31, 2014
Messages
7
Motherboard
HP Envy 17t-3200 CTO 3D Edition/Yosemite-Chameleon
CPU
3rd Gen Core i7-3820QM @ 2.70 GHz Quadcore
Graphics
AMD Radeon HD 7850M/8850M
Mac
Classic Mac
Mobile Phone
iOS
Hi, I've managed to get it worked.
The problem is in the new AMDRadeonX4000.kext.
The new values in 10.10.3 for "cail_properties" of AMDVerdeGraphicsAccelerator driver are:
<dict>
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>0</integer>
</dict>
The old values (in 10.10.2) was:

<dict>
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>1</integer>
</dict>
Once I change it back in Info.plist and clear kext cache, my system boots without problems.
It worked for my 7850m card. Thank you so much!
 
Joined
Jun 23, 2013
Messages
4
Mac
Classic Mac
Mobile Phone
it really works, thanks very much

here is how to:
use -v -s booting args to boot into single user mode
mount -o update /
cd /system/library/Extension/AMDRadeonX4000.kext
edit the info.plist under kext by vi or other text editor
save your edit then reboot with -v -x (into safe mode)
login then use kext wizard to rebuild the cache (with out 3d acceleration,it's very very lag...:beachball:)
after kext rebuild , reboot, all down and it works!:lol:
 
Joined
Mar 12, 2015
Messages
36
Motherboard
Asus X99-E WS
CPU
Intel Xeon E5-1650v3
Graphics
MSI GeForce GTX 960 GAMING 4G 4096MB GDDR5
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Hi,

I have the same problem with 10.10.3 too. 10.10.1 worked fine for me. Using the Sapphire Ultimate R7 250 1GB GDDR5. Can you fix the kext please for me?
 
Joined
May 20, 2013
Messages
29
Motherboard
Acer Aspire V3-772G
CPU
Core i5 4210M
Graphics
Intel HD 4600 - GTX 850M (disabled)
Mac
MacBook Air
Classic Mac
eMac, iBook, iMac, Power Mac
Mobile Phone
Android
C'mon, it's six posts above, see #42 :rolleyes:
 
Joined
Mar 12, 2015
Messages
36
Motherboard
Asus X99-E WS
CPU
Intel Xeon E5-1650v3
Graphics
MSI GeForce GTX 960 GAMING 4G 4096MB GDDR5
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Still glitches here. Even with new kexts.
 
Top