Contribute
Register

10.10.3 Update Black screen with cursor

Joined
May 9, 2011
Messages
5,936
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Gigabyte GTX 970 WINDFORCE / Intel HD Graphics 530
Mac
iMac
Mobile Phone
iOS
I'll try that, what exactly is meant by clearing the kext cache and how do i do it?
Open Kext Wizard, goto Maintenance tab. There you can see the options for repairing disk permissions and rebuilding kext caches. Select it then execute

Screen Shot 2015-04-09 at 11.09.24 pm.png
 
Joined
Nov 16, 2014
Messages
11
Motherboard
Asrock P67 PRO3(Clover)
CPU
i7 2600K
Graphics
HD 7750
Mac
Classic Mac
Mobile Phone
It worked! Just edited the info.plist from the x4000 kext and executed the kextwizard as told.

Thanks a ton to Jithin C.V. and olegt!
 
Joined
Apr 9, 2015
Messages
6
Motherboard
Asrock H61M-DGS
CPU
Intel i3-3240
Graphics
AMD HIS Radeon 7770
Mac
Classic Mac
Mobile Phone
Can anyone send me all needed AMD kexts for 7770, I'm not able to make it work and I have deleted it :rolleyes:

Thanks in advance
 
Joined
Apr 9, 2015
Messages
6
Motherboard
Asrock H61M-DGS
CPU
Intel i3-3240
Graphics
AMD HIS Radeon 7770
Mac
Classic Mac
Mobile Phone
Thanks, I'm going to try.

EDIT: Don't know why, but it's not loading any kext, so is not detecting the graphics card. :?::?:
 
Joined
Nov 16, 2014
Messages
11
Motherboard
Asrock P67 PRO3(Clover)
CPU
i7 2600K
Graphics
HD 7750
Mac
Classic Mac
Mobile Phone
Thanks, I'm going to try.

EDIT: Don't know why, but it's not loading any kext, so is not detecting the graphics card. :?::?:
Maybe try the same fix I used? It's on page 2 of this thread. Afterwards download kexwizard and click rebuild cache and repair permissions and execute.
 
Joined
Apr 9, 2015
Messages
6
Motherboard
Asrock H61M-DGS
CPU
Intel i3-3240
Graphics
AMD HIS Radeon 7770
Mac
Classic Mac
Mobile Phone
Also done this, and it's not working ;/
 
Joined
Oct 13, 2010
Messages
5
Motherboard
Asus P7P55D-E PRO
CPU
i7 860
Graphics
GeForce GTX 970
Hi, I've tried to put a link, but the message didn't appear.
I've managed to get it worked, thanks to some russian forum.
The problem is in the new AMDRadeonX4000.kext.
The new values in 10.10.3 for "cail_properties" of AMDVerdeGraphicsAccelerator driver are:
<dict>
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>0</integer>
</dict>
The old values (in 10.10.2) was:

<dict>
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>1</integer>
</dict>
Once I change it back in Info.plist and clear kext cache, my system boots without problems.
This also worked for me. Thank you very much. I had been trying to install betas but this happened on all of them except the first so I was stuck on that one. :D
 
Joined
May 3, 2014
Messages
5
Motherboard
ASUS A53E/K53E
CPU
2.49 GHz Intel Core i5 2450M Processor
Graphics
Intel HD 3000
Mac
Classic Mac
Mobile Phone
Having problems with my Radeon HD 7770. I've tried everything in this thread but still black screen halfway through the boot process...
 
Top