Contribute
Register

10.10.3 Update Black screen with cursor

Joined
Oct 9, 2012
Messages
4
Motherboard
Asus P8Z77V-PRO
CPU
Intel i5 3570K
Graphics
Sapphire Radeon HD7770
Mac
Classic Mac
Mobile Phone
Everything is okay with 10.10.2 but I had the same problem with 10.10.3 beta + final updates. I can't get HD7770 working.
 
Joined
May 9, 2011
Messages
5,937
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Gigabyte GTX 970 WINDFORCE / Intel HD Graphics 530
Mac
iMac
Mobile Phone
iOS
Everything is okay with 10.10.2 but I had the same problem with 10.10.3 beta + final updates. I can't get HD7770 working.
Which boot loader?? If you are using clover then see post#5
 
Joined
May 9, 2011
Messages
5,937
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Gigabyte GTX 970 WINDFORCE / Intel HD Graphics 530
Mac
iMac
Mobile Phone
iOS
Thanks. I added a picture in the attachment.
Select the FBConfig, Press enter type "Futomaki" press enter. Return to boot menu, try booting.
 
Joined
Apr 9, 2015
Messages
6
Motherboard
Asrock H61M-DGS
CPU
Intel i3-3240
Graphics
AMD HIS Radeon 7770
Mac
Classic Mac
Mobile Phone
I can't get working HD 7770 on 10.10.3 too. Previous 10.10.2 was fine, but now kext won't load. I'm not using any FB.

System : Asrock H61M-DGS + Chameleon r2538
CPU : Intel i3 - 3240
Graphics : HIS Radeon HD 7770


Thanks!
 
Joined
Nov 6, 2012
Messages
8
CPU
I7 4770K
Graphics
ATI7770
Mac
Classic Mac
Mobile Phone
Hi, I've managed to get it worked.
The problem is in the new AMDRadeonX4000.kext.
The new values in 10.10.3 for "cail_properties" of AMDVerdeGraphicsAccelerator driver are:
<dict>
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>0</integer>
</dict>
The old values (in 10.10.2) was:

<dict>
<key>CAIL_DisableDrmdmaPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableDynamicGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGfxCGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableGmcPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableStaticGfxMGPowerGating</key>
<integer>1</integer>
<key>CAIL_DisableUVDPowerGating</key>
<integer>0</integer>
<key>CAIL_DisableVCEPowerGating</key>
<integer>1</integer>
</dict>
Once I change it back in Info.plist and clear kext cache, my system boots without problems.
 
Joined
May 9, 2011
Messages
5,937
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Gigabyte GTX 970 WINDFORCE / Intel HD Graphics 530
Mac
iMac
Mobile Phone
iOS
I can't get working HD 7770 on 10.10.3 too. Previous 10.10.2 was fine, but now kext won't load. I'm not using any FB.

System : Asrock H61M-DGS + Chameleon r2538
CPU : Intel i3 - 3240
Graphics : HIS Radeon HD 7770


Thanks!
Are you able to boot??

If you are using Chameleon then try booting with "GraphicsEnabler=No AtiConfig=Futomaki -f"
 
Joined
Apr 9, 2015
Messages
6
Motherboard
Asrock H61M-DGS
CPU
Intel i3-3240
Graphics
AMD HIS Radeon 7770
Mac
Classic Mac
Mobile Phone
Are you able to boot??

If you are using Chameleon then try booting with "GraphicsEnabler=No AtiConfig=Futomaki -f"

Yes, I can boot, but not loads any AMD kexts. Later will try what you say because I'm not at home. Thanks!
 
Top