Contribute
Register

"000000.841844 AppleUSBLegacyRoot@: AppleUSBLegacyRoot::init: enabling legacy matching" while trying

Status
Not open for further replies.
Joined
Nov 21, 2014
Messages
13
Motherboard
X370 Xpower Gaming Titanium
CPU
Ryzen 7 1800X
Graphics
GTX 1080
Did not work for me! Rampage IV Gene.

Solved by using 3.0 ports with GenericUSBXHCI.kext.
 
Last edited:
Joined
Jun 16, 2017
Messages
1
Motherboard
i845 Intel
CPU
Pentium 4
Graphics
Nividia 32MB
same issue here

----- update may 25, 2016-----
Fixed by:

1. Run EFI Mounter v3.app to mount boot disk. Edit the Clover config.plist (/Volumes/EFI/EFI/CLOVER/config.plist) in boot disk.

<key>Devices</key>
......
<key>USB</key>
<dict>
<key>FixOwnership</key>
<true/>
<key>Inject</key>
<true/>
</dict>​

2. Copy the downloaded FakeSMC.kext and USBInjectAll.kext to /Volumes/EFI/EFI/CLOVER/kexts/Other/

Thank you so much!

I use Dell OptiPlex 3040. I passed this error after I follow your guide. But I only need use step 1 (set 2 false to true). And 2 files in step 2 existed in this folder.
Note: I setup macOs Sierra follow this link: https://www.tonymacx86.com/threads/...any-supported-intel-based-pc.200564/#download
 
Joined
Mar 12, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
I also was able to get past that error using the enable USB ownership in the options section of clover during installation to get to the install screen (after I had to do this also http://www.tonymacx86.com/threads/kernel-panic-help-requested-please.192385/)

You're my savior.

I've been looking for an answer to my problem for a while now, and enabling USB ownership is the only thing that did it. My screen would just get stuck on the boot logo. I looked through all my bios at least 10 times and I wasn't able to see what was wrong. I had the same problem last year when I tried to install OS X on my Windows and I couldn't find an answer to it. I was about to give up, but thank god I came across this.
 
Joined
Nov 8, 2016
Messages
29
Motherboard
Gigabyte Z170X-Designare
CPU
i7
Graphics
GTX 950
Mac
  1. iMac
Joined
Feb 2, 2019
Messages
16
Motherboard
Asus TUF X299 Mark 2
CPU
i7-9800X
Graphics
RTX 2080
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
By the way, if you are having problems in Mojave this solution by going into settings > pci devices > and then check off usb ownership it works too!
 
Joined
May 2, 2019
Messages
8
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900k
Graphics
Vega 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
1. Run EFI Mounter v3.app to mount boot disk. Edit the Clover config.plist (/Volumes/EFI/EFI/CLOVER/config.plist) in boot disk.

<key>Devices</key>​
......​
<key>USB</key>​
<dict>​
<key>FixOwnership</key>​
<true/>​
<key>Inject</key>​
<true/>​
</dict>​

I want to say THANKYOU
change from both <false/> to <true/> safe my day :)
 
Status
Not open for further replies.
Top