Contribute
Register

"000000.841844 AppleUSBLegacyRoot@: AppleUSBLegacyRoot::init: enabling legacy matching" while trying

Status
Not open for further replies.
Joined
Jan 21, 2016
Messages
6
Motherboard
GIGABYTE GA-B250-HD3P
CPU
i7-7700K
Graphics
Geforce 1080
Freeze while trying to boot into OS X installer

Hello,
I am trying the first time to install a hackintosh. I followed step by step this guide, but step 4 does not work for me. I only get the printed out "000000.841844 AppleUSBLegacyRoot@: AppleUSBLegacyRoot::init: enabling legacy matching", when I am trying to start the installer. I tried these boot-parameters: "-x"; "nv_disable=1";. Also I tried to deactivate my Nvidia Graphics Card and use instead of the Intel. I tried as well usb 2.0 ports as well as usb 3.0. I already googled a little bit around but I did only found posts, where this error happened after installing and error collection threads, where this problem were only described by a user, but never solved.
IMG_0032.jpg
My HardWare:
Mainboard:
  • Mainboard: H110-S2HP
  • Intel Core I7-6700
  • Nvidia Geforce 980
  • DDR4 Ram
 
Joined
Sep 1, 2014
Messages
2,955
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Please put your specific motherboard model into the system configuration area on the left. It's hard to give you good advice without having that information on hand on every post (just listing it in that first post is not enough).

Then, have you looked at the http://www.tonymacx86.com/el-capitan-desktop-guides/179221-skylake-starter-guide.html? It's still a little manual at this point, but you will need a number of those fixes to install on a Skylake board.
 
Joined
Apr 16, 2016
Messages
1
Mac
Classic Mac
Mobile Phone
@00pflaume -
I am stuck at the same point? Did you find a solution for this?
 
Joined
May 19, 2016
Messages
8
Motherboard
ASRock H170m-itx/ac
CPU
Intel Core i5 6500
Graphics
Intel HD Graphics 530
same issue here

----- update may 25, 2016-----
Fixed by:

1. Run EFI Mounter v3.app to mount boot disk. Edit the Clover config.plist (/Volumes/EFI/EFI/CLOVER/config.plist) in boot disk.

<key>Devices</key>
......
<key>USB</key>
<dict>
<key>FixOwnership</key>
<true/>
<key>Inject</key>
<true/>
</dict>​

2. Copy the downloaded FakeSMC.kext and USBInjectAll.kext to /Volumes/EFI/EFI/CLOVER/kexts/Other/
 
Last edited:
Joined
May 20, 2016
Messages
1
Motherboard
MSI Z170A Gaming Pro (BIOS v1.90)
CPU
i7 6700k
Graphics
AMD Radeon R9 290
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Running into the same thing with my skylake. Were either of you able to find a way around it? Thanks,
 
Joined
Jun 11, 2016
Messages
3
Hello,

The patch of "update may 25, 2016" works well when computer boot on USB key (files copies from Volumes/EFI/EFI/CLOVER/kexts/10.11)

But the boot process still stop on "AppleUSBLegacyRoot@: AppleUSBLegacyRoot::init: enabling legacy matching" when I'm trying to boot on installed El Capitan (10.10.5) on hard drive.
 
Joined
Apr 9, 2016
Messages
1
Motherboard
dell-inspiron-5559__clover__
CPU
Intel Skylake i7-6500u 2.5GHz++mainboard skylake-u
Graphics
intel 520 graphics+ amd readeon r5 335m 4Gb + 1920*1080
Hi,

same problem as MattOZ here to install with a hard drive. Any thoughts on this?
Thanks
 
Status
Not open for further replies.
Top