xfx r9 280x

  1. theSUBVERSIVE

    [HELP!] GA-Z77-DS3H rev 1.1 + XFX R9 280X DD - Trapped in a Boot Loop

    GA Z77 DS3H rev. 1.1 i5 3570K I bought this XFX 280X as a GPU upgrade over my old 650 Ti. I've installed latest version of High Sierra just with the integrated graphics, everything ok. Installed Multibeast, it didn't boot. Because of problems latest time I did a full installation, I used...
  2. Tom86

    r9 280x working OOB in El Capitan but won't work in Sierra

    Hi, Can someone please help or point me in the right direction. I got a xfx r9 280x that is working perfectly OOB with El Capitan with full acceleration. I’ve recently upgraded to Sierra and can’t seem to get it to boot without –x flag. With ATI Injection enabled I get really sluggish...
  3. sundarcali

    Ocassional SYSTEM CRASH - Screen freezes white.

    OSx: Yosemite 10.10.3 on EFI (Clover) MOBO: MSI z97 SLI Krait Edition CPU: 3.6 GHz Intel Core i7 - 4790 GPU: XFX R9 28x RAM: 16 GB 1600 MHz DDR3 SSD: KINGSTON 240G SV300S37A POWER: thermaltake 600w Everything works fine... and around 4 months ago I started getting few times a day system crashes...
  4. wandyliem

    Black Screen no signal XFX R9 280X DD (TDF)

    Hi guys i have problem using this card like the tittle said i got no signal. i tried everthing but fail except -x (safe mode). so everytime i want to use hackintosh (yosemite) i should pass -x. my sepcs: Yosemite 1.0.1.0 i5-3570K Gigabyte Z77X-UD5H 2 Sticks of RAM,8GB kit Samsung SSD for OS X...
  5. Maflagulator

    XFX R9 280x on GA-Z87X-UD7-TH with Safe Mode only....

    I have installed the Bootloader and Extra Folder onto the EFI partition but my XFX can only boot up in safe mode. I've been searching to no end for someone with at least the same card. Other with the R9 280x, but different brand, are having perfect OOB compatibility. If I boot with the...
Top