Search results

Loading Google Results...
  1. pbryanw

    AMD Radeon Navi GPU

    First of all, thanks for this great thread @Gigamaxx, and to all those who have contributed to it. It helped me decide that my next graphics card was going to be a 5700 XT. I was originally going to buy a Sapphire Nitro+ 5700 XT, but the MSI Gaming X 5700XT was slightly cheaper here in the UK...
  2. pbryanw

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Yes, I've enjoyed following your progress over on the discussion thread on InsanelyMac - thanks, I found it very useful & informative :thumbup: There's a steep learning curve with OpenCore (at least for me) and as mentioned, it's yet to reach beta status, so each update has plenty of changes. I...
  3. pbryanw

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    I've also been having a play with OC, version 0.04. This started because my Gigabyte Aorus Pro Wifi was having boot issues with OsxAptioFix2Drv-free2000.efi in Clover (about 1 in 6 boots would end in a black screen). I'd also read forum posts warning against using this driver. As you mention...
  4. pbryanw

    [Success] Skylake Asus Maximus VIII Ranger, i5-6600, GTX 1070 (Clover/High Sierra)

    @vodinh0000 - Hi, can I ask why you need my DSDT? For what purpose is it required? To be honest, I no longer use a DSDT for my hackintosh build - it' not needed - and quickly becomes outdated. I only use a custom SSDT for my USB ports, so they're all recognized by macOS...
  5. pbryanw

    [SOLVED] Sierra HiDPI scaling issues

    @tqbinh - Hi, that's great to hear! It's great when you find the fix to a problem you're facing. Thank you for the update, and for sharing your solution :thumbup:
  6. pbryanw

    [SOLVED] Sierra HiDPI scaling issues

    @tqbinh - Hi, apologies for the late reply - I've been away from home for the past week. Regarding your request to post my config file - my PC has been upgraded since I made that post, so I think my current config wouldn't be relevant to your computer. What I can do is attach some screenshots...
  7. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    Hi, hope it's ok to go slightly off topic, though it's still related to this thread. I was wondering how others reboot their PC, when they make changes to their iGPU configuration, which end up in a black screen on boot? For a long time, I've used the reset button on my PC when this happens...
  8. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Thanks for the link - that's brilliant! Following these steps by @itwas fixed my sleep issue too, and I now have working sleep in Mojave, with my onboard UHD 630 graphics :) That just leaves native NVRAM, as the only thing that isn't fully supported on my Z390 system. I've been...
  9. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    Hi, I hope you don't mind if I interject here. I currently use an adapter like this to output my GTX 1070's DP port to a HDMI TV, and it works well in this task: https://www.amazon.com/dp/B010SDZZ80/?tag=tonymacx86com-20 I don't know which country you are in, so I've included the link to the US...
  10. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    A big thank you from me :thumbup: Your new guide was really easy to understand & follow - to an average user like me. And after reading the overhauled version, it all made a lot more sense to me (I hope). So, in a nutshell (if I understand correctly), macOS provides three software connectors...
  11. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Hi, I'm happy to report that your "Technically correct" configuration is working perfectly for me (with full iGPU acceleration using my HDMI monitor). The "Technically Correct" configuration (created in Hackintool) is in the spoiler below: Regarding DP output, I'll have to leave...
  12. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Ok, I've attached a screenshot of FBPatcher (now Hackintool) to this post, after carrying out your instructions. I think I've captured the port number. I used FBPatcher 1.7.1 to do this. Thanks again, and I look forward to reading your updated guide after you complete your final...
  13. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    Firstly, thanks for all your hard work on this - without which, I (and others) wouldn't have fully working onboard graphics in macOS. Here are the results of verifying the two configurations you created for my Z390-A motherboard. I've included the framebuffer configurations I created for both...
  14. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Hi, many thanks for your explanation - this makes sense to me now. I'll leave the "pipe" keys in for now, so I can use the Hotplug Reboot Fix, while removing the "flags" keys.
  15. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Hi, I was messing about with the code for my UHD 630's framebuffer injection, and noticed that I could delete the pipe & flag keys from its properties (in config.plist), with seemingly no effect on the patch's function. I'm just wondering if you know whether these keys are needed in...
  16. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Hi, glad to help. I've included screenshots from FBPatcher for both of the requested ports, in the spoilers below: My ASUS Prime Z390-A Motherboard has 1 x HDMI Output & 1 x DP Output for its Intel iGPU.
  17. pbryanw

    ASUS ROG STRIX Z390-I Gaming Motherboard specs

    @Toad - Thanks, I read your post on the Z390 and i7-8700K - any successful builds? thread, and it was your post that led me to using the -no_compat_check boot-arg - a big thank you for your help as well. I'd also be interested whether you are using DP output for your UHD 630? In my case, I...
  18. pbryanw

    [GUIDE] General Framebuffer Patching Guide (HDMI Black Screen Problem)

    @CaseySJ - Hi, thank you for this guide. I've been able to get the Intel UHD 630 Graphics on my i5-9600K CPU working with acceleration, thanks to your help. I used the patch for the "ASUS Prime H370-Plus and Coffee Lake CPU" in your original post (I think you've read my post detailing this on...
  19. pbryanw

    ASUS ROG STRIX Z390-I Gaming Motherboard specs

    Hi, after searching for a way to get the Intel iGPU on my i5-9600K CPU working with acceleration, I came across this excellent new guide by @CaseySJ today on tonymacx86: https://www.tonymacx86.com/threads/guide-general-framebuffer-patching-guide-hdmi-black-screen-problem.269149/ It's helped me...
  20. pbryanw

    ASUS ROG STRIX Z390-I Gaming Motherboard specs

    Hi, sorry for the very late reply (more about this later). I've tried using the WEG kext (which has just been updated) but, although I can get a picture using the iGPU on my motherboard, graphics acceleration doesn't work under macOS (my UHD 630 shows up as a generic 14MB display adapter). I...
Top