Contribute
Register

Search results

Loading Google Results...
  1. vbo

    [Guide] Dell XPS 13 9333 using Clover

    You should probably follow RehabMan's advice. Not that it will help you much but I just tested mine and it works fine, both image and sound.
  2. vbo

    [Guide] Dell XPS 13 9333 using Clover

    I'm afraid I can't help since I don't have the same GPU (HD4400 here). Isn't HD5000 the GPU used in the macbook chips from that era? If I remember correctly, 0412:8086 is actually HD5000. In your case you probably don't need either FakePCIID_IntelHD_Graphics (it won't load anyway since it...
  3. vbo

    [Guide] Dell XPS 13 9333 using Clover

    I'm using RehabMan's voodoops2 with 3 fingers swipe up/down/left/right set to OSX defaults via dsdt. No complaints.
  4. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Upgraded to 10.12.6, no issues.
  5. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Repo is at: https://github.com/vbourachot/Dell-XPS13-9333-DSDT-Patch You clone it to your local machine in step 5.3. I think if you follow the first post as is, it should work fine. Only change would be in step 5.4 where you don't need to download intelbacklight kext anymore. Instead, use...
  6. vbo

    [Guide] Dell XPS 13 9333 using Clover

    In case anyone is still reading this old thread.. I updated my rock stable 10.11.6 to 10.12.4 (via the app store update) last night. Everything works fine after following the recommendations in the first post of the readme that RehabMan posted above. I pushed the necessary changes for 10.12.4 to...
  7. vbo

    [README] Common (some unsolved) Problems in 10.12 Sierra

    Just another datapoint to say the modified patches in post #939 worked for me too on 10.12.4 with my haswell laptop. No lag after sleep/login and mini-dp out working with sound. I actually did the in place update from trusty 10.11.6 to 10.12.4 and everything works fine after doing the fixes...
  8. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Define "issues"...
  9. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Try booting linux (live usb is fine) and post the output of lspci -nn. Have you checked in the bios that the wifi is not disabled? (I'll be honest I can't remember if there's a bios setting but it's worth looking through).
  10. vbo

    [Guide] Dell XPS 13 9333 using Clover

    What do you mean the config.plist doesn't work with the latest version of clover? It isn't loaded? Do you get an error in the boot log or something?
  11. vbo

    BCM94352Z (DW1560) 5GHz working natively without the patch?

    Same here. Mine's not Dell branded though, it's one of the original engineering samples that I got from china back in 2014 (back when it cost an arm and a leg). But yeah, it's been connected to my 5ghz home network (n and then ac) without a kext patch since 10.10 up to 10.11.6.
  12. vbo

    [Guide] Dell XPS 13 9333 using Clover

    In your local copy of my github repo, under the ssdt/ folder (ssdt.aml). That will only make it sweeter when it gets to you :)
  13. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Nullethernet should work once you add the kext. Getting a compatible wifi card (e.g., bcm94352z) is a much better long term solution though as the third party drivers for usb wifi often break sleep (and their GUI are usually crap). As far as PM ssdt, you can use mine if you want to as long as...
  14. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Nullethernet kext: https://github.com/RehabMan/OS-X-Null-Ethernet The audio and framebuffer patches are part of the config.plist. Compare your config.plist KernelAndKextPatches/KextsToPatch/ section with the one here...
  15. vbo

    [Guide] Dell XPS 13 9333 using Clover

    It's in the guide, last bp of the last section: That's the least of your problem though.. The incorrect config.plist is really the reason why you're seeing most of your issues. I believe the guide is fairly clear as to which config.plist to use, how to generate ssdt.aml for power management...
  16. vbo

    [Guide] Dell XPS 13 9333 using Clover

    I'm not sure where you got the config.plist you're using but it's not the one I use in the repo. It's no surprise that sound isn't working when you're missing 3 out of the 4 required applehda patches, and it's also missing the framebuffer patch which likely explain the screen corruption you're...
  17. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Which point version of 10.10 did you install? It kinda looks like a framebuffer issue.. there's a patch for it in my config.plist but I'm not sure it works against early 10.10 versions as I remember the kext changed quite a bit until 10.10.3 or so. Personally I'd update (or clean install.. now...
  18. vbo

    [Guide] Dell XPS 13 9333 using Clover

    Sure, use a recent version of clover. I know rehabman recommends a specific one in one of his stickied post (FAQ maybe) since the very latest ones have been buggy.. Post your questions in here and I'll reply.. better to have it public if someone else needs the info later.
  19. vbo

    [Guide] Dell XPS 13 9333 using Clover

    You should be able to follow the guide in the first post with a 10.11 USB installer. I haven't tested it recently but I don't see why it wouldn't work. If you have any issues just ask and I'll try to help out and update the guide.. OSX host and linux VMs are the way to go if you ask me..
  20. vbo

    Getting ALC668 to work?

    Third paragraph in this post details how to create an injector (dummyhda) for alc668: ALC 668 only works well after restarting from Windows You'll need to inject layout-id 1 and have the usual dsdt patches required for audio (refer to RehabMan's guide). You'll also need codec commander to get...
Top