Recent content by pupin

  1. pupin

    Mojave on ASRock Z390 Phantom Gaming-ITX/ac

    Native nvram does not work on Z390. Aptio guys did not fix it yet, that's false news.
  2. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    Hi @rj510, did you see this writeup this regarding TB3 hotplug?
  3. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    It's working pretty much the same as Mojave.
  4. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    I checked, there are no changes related to hackintosh. The BIOS is very similar with v4.0. Same DSDT bug also, so fix is also still needed.
  5. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    One more question, also about HD Intel graphics. Occasionally, the screen blacks out for about 1-2 seconds and then image returns as if nothing happened. Is this the "flickering" you were referring to earlier?
  6. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    Yes as I mentioned above it seemed that updating WhateverGreen fixed the issue. I also see in WhateverGreen commit log a note about KPs starting with 10.14.4, so that is probably what I was experiencing.
  7. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    Thank you for the answer. Meanwhile I updated WhateverGreen to latest version and it possibly solved the random reboots. I say possibly as it happened only sometimes, so it remains to be seen...
  8. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    Hi @rj510, I recently got rid of my GPU and started using the Intel HD Graphics for this board. Since then I am experiencing random reboots, so it clearly has to do something with the Graphics. Have you had this? Any idea what it can be?
  9. pupin

    [100% Working] 12+6 Pin Apple WiFI/BT Card to M.2 NGFF Adapter! Handoff! Unlock with Watch! UEFI!

    I got this from eBay. But it's not the only option. I chose that as it is an original apple card with an adapter, everything in one kit so I don't need to run to post office twice...
  10. pupin

    [100% Working] 12+6 Pin Apple WiFI/BT Card to M.2 NGFF Adapter! Handoff! Unlock with Watch! UEFI!

    I am in BIOS 4.0 and when I got the board it was on 1.2. It worked on the first attempt, and has worked ever since. Which card exactly do you have? Maybe it is defective or something doesn't make good contact
  11. pupin

    [100% Working] 12+6 Pin Apple WiFI/BT Card to M.2 NGFF Adapter! Handoff! Unlock with Watch! UEFI!

    If it's of any help, I asked AsRock the same question for my Z390-PhantomGaming-ITX/ac. And got a very similar response. Yet, after buying it, I figured out it does work.
  12. pupin

    Mojave on ASRock Z390 Phantom Gaming-ITX/ac

    Glad you got it sorted out!
  13. pupin

    Mojave on ASRock Z390 Phantom Gaming-ITX/ac

    Honestly I didn't really notice anything. It works just like the previous ones did.
  14. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    No, but honestly I didn't even try as I didn't need it on Mac. What I did notice (under Windows), is that that port is connected to an altogether different XHCI controller. The main XHCI controller is VEN_8086&DEV_A36D (Cannon Lake PCH USB 3.1 xHCI Host Controller) And that USB-C port is on...
  15. pupin

    [Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

    Hi @rj510, As I had a front USB port problem also, I checked again the front ports. This time I got to a different result: Front Panel left - HS10,SS07 (I said SS10 here before instead of SS07) Front Panel right - HS11,SS08 (same like before) I am not sure how come I got to a different result...
Top