Recent content by contemporarygary

  1. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Yes, unfortunately the hotplug still doesn't work unless I disable the BIOS Assist mode. Your solution should improve the battery life in theory, I'll have to do some more testing There's a hardware BIOS mod that unlocks the advanced settings, you can read more on that here. The "GPIO3 Force...
  2. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Just finished flashing the firmware. Soooo it works now! Had to use Thunderbolt3Unblocker to make my TB16 dock work, otherwise it says "unsupported" in the Thunderbolt menu (attached) Hotplug works both with and without the TB3 device present at boot. Will do some more test with BIOS Assist...
  3. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    I'm on board with that! Don't have Windows installed on this machine, so that's fine by me.
  4. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    a) with Thunderbolt dock connected on boot: Monitor works, USB devices (keyboard and mouse) don't. Thunderbolt section in System Profiler says "No drivers", CPU sits at 80 degress with 3.80Ghz, gets back to normal as soon as I unplug the Thunderbolt cable. When I unplug the cable, the laptop...
  5. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Good news: the rename worked Bad news: still nothing in "Thunderbolt" menu in System Profiler, and no hotplug. Moreover, before the monitor would hotplug just fine, but USB wouldn't work – now neither monitor nor USB work via Thunderbolt. Also, my CPU ramps up to 3.80Ghz when Thunderbolt is...
  6. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Turns out I had an unrelated Thunderbolt kext that might've been doing that. I did another DSDT dump, looks like the rename isn't happening anymore. It's _INI now.
  7. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Thank you! Sure thing. So I wouldn't need the SSDT-Z390-TB3HP anymore? (attached) UPD: Tried booting with the SSDT you provided and without SSDT-Z390-TB3HP, Thunderbolt works on boot, but no hotplug
  8. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    Thank you! I'm attaching the files to this message. I have one concern though, wouldn't this DSDT also include the SSDTs and ACPI patches injected with OpenCore? I'm currently using SSDT-Z390-TB3HP.aml and a couple of hotpatches for the TB hotplug
  9. contemporarygary

    [SUCCESS] Gigabyte Designare Z390 (Thunderbolt 3) + i7-9700K + AMD RX 580

    First of all, @CaseySJ and @Elias64Fr, thank you very much for your hard work! I have a laptop, Thinkpad X1 Carbon 6th gen with an Alpine Ridge Thunderbolt chip. Thunderbolt works just fine (including hotplug) without the "BIOS Assist" option in the BIOS, but adds about 2W to the CPU package...
  10. contemporarygary

    [Guide] Lenovo ThinkPad T440P

    I managed to fit an Airport card from MBA 2012 (BCM943224PCIEBT2) into my T440p! Here's a how-to: https://github.com/notthebee/t440p-airport
  11. contemporarygary

    Install Dell DW1820A (Broadcom BCM94350ZAE)...

    I've attached the debug output to this post: https://www.tonymacx86.com/threads/install-dell-dw1820a-broadcom-bcm94350zae.265130/page-13#post-1984432
  12. contemporarygary

    Install Dell DW1820A (Broadcom BCM94350ZAE)...

    The label on mine says CN-0VW3T3, judging by this thread it should be 100% compatible. However, unless I specify brcmfx-driver=1 or install the kext from Yosemite, my laptop won't even boot
  13. contemporarygary

    Install Dell DW1820A (Broadcom BCM94350ZAE)...

    To be honest I don't understand how to translate the IORegistryExporer notation into the CLOVER one. (pci14e4,43a3 becomes ARPT if I enable FixAirport in Clover, but still no WiFi) A couple of questions: 1.) What version are you running? I've heard that most of the solutions stopped working in...
  14. contemporarygary

    Install Dell DW1820A (Broadcom BCM94350ZAE)...

    I don't have Windows, so I used gfxutil to determine the PCI address
Top