Recent content by BlvckBytes

  1. BlvckBytes

    << Solved >> OpenCore battery patch

    @BeatsMan286 Just to make sure... do you get a properly working battery indicator by making use of ECEnabler? Seems like we're maybe kind of mixing up two different problems here, which may have different root causes.
  2. BlvckBytes

    << Solved >> Do the Samsung 970 EVO Plus drives work ? New Firmware Available 2B2QEXM7

    @deepblonde I have no issues with the SN750, and 2TB should work just fine.
  3. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen How did you check that _STA actually returned 0xF? Did you ensure in IOReg? Just wanting to make sure.
  4. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen Is there a way you could provide more lines of the log, as that is just too little info to make sense of anything? // Edit: Found another typo, updated attached files
  5. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen I'm sorry, I totally messed up on the region patch using duplicate names, please try again. Now, those AE_ALREADY_EXISTS errors should be gone. If you still experience the _STA issues, it would be interesting to know if they only appear on boot, since the region handler should now...
  6. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen I'm not yet sure why your system tripped up on _STA, since it only uses an 8 bit sized field inside the if-statement. I now patched _BST and _BIF by creating a custom SSDT-BATT, please give this a try. If it still trips up, re-attach the *current* output of Hackintool from boot...
  7. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen Just to make absolutely sure, please try the attached version of your EFI folder. If that still yields the same result, I guess you need a custom battery patch - for whatever reason. This will take some time.
  8. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen And you've tried to only load this kext, without any acpi manipulation regarding Battery/EC? If so, I'll look into your files.
  9. BlvckBytes

    << Solved >> OpenCore battery patch

    @tingyichen Have you already had a look at ECEnabler.kext, did that not work in your case?
  10. BlvckBytes

    << Solved >> Do the Samsung 970 EVO Plus drives work ? New Firmware Available 2B2QEXM7

    @panosru Weird, I didn't see any difference between our configs, except that I have a trim-timeout of -1, which then again should be default, and should still yield slow boot times when trim doesn't work. You could just set it to like 500 and forget about it, although it's inefficient. But hey...
  11. BlvckBytes

    << Solved >> Do the Samsung 970 EVO Plus drives work ? New Firmware Available 2B2QEXM7

    @panosru Hey there and sorry for my late response! I just downloaded smartmontools using homebrew, and then ran sudo smartctl --all /dev/disk<your-id>, to quickly check what firmware version I'm running. Funny enough, I'm on 2B2QEXM7 too, running Monterey. If you don't mind, attach your full...
  12. BlvckBytes

    XPS 9700 audio - Comet Lake PCH cAVS, any chances?

    @thewhoareyou Could you please explain how you achieved it now? What was wrong before?
  13. BlvckBytes

    XPS 9700 audio - Comet Lake PCH cAVS, any chances?

    @thewhoareyou Hard to tell how much it really adds, since I'm also running on AC all the time, lol. And yup, mine also hovers around 1.3 GHz, bummer, 800 MHz would be amazing!
  14. BlvckBytes

    XPS 9700 audio - Comet Lake PCH cAVS, any chances?

    @thewhoareyou Have you generated CPUFriendFriend yourself, and updated to latest CPUFriend? But anyways, believe me, undervolt. It's worth it. You just need to use an efi file to boot into a GRUB shell from OpenCore's tools, and then clear two memory addresses. Not that big of a deal, and you...
  15. BlvckBytes

    XPS 9700 audio - Comet Lake PCH cAVS, any chances?

    @thewhoareyou Are you undervolting? That yields some extra battery life.
Top