Turn on/off Bluetooth

Discussion in 'HP ProBook 4530s' started by oradoe, Jun 23, 2012.

  1. oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Jun 23, 2012 #1
    oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Hi, does anyone know how can we deliberately toggle (built-in) bluetooth? For example, I have a bluetooth headset paired with both HackBook and iPad, which, be design catch the first device it can. Thus, if I want to switch from my HackBook to my iPad, I really need to turn off bluetooth on my HackBook.
    Thank you in advance
     
  2. nikstar

    nikstar

    Joined:
    Jun 19, 2010
    Messages:
    674
    Mobo:
    4530s
    CPU:
    i3 2330
    Graphics:
    HD3000
    Classic Mac:
    Power Mac
    Mobile Phone:
    Android, Windows Phone
    Jun 24, 2012 #2
    nikstar

    nikstar

    Joined:
    Jun 19, 2010
    Messages:
    674
    Mobo:
    4530s
    CPU:
    i3 2330
    Graphics:
    HD3000
    Classic Mac:
    Power Mac
    Mobile Phone:
    Android, Windows Phone
    You can't. Even if you switch it off at bios, OSX still can "see" it.

    Do a search here for a "taped" solution.
     
  3. oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Jun 25, 2012 #3
    oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    I am not sure whether I can turn it off in BIOS, but to My knowledge, I can turn it off if I manage to boot to Ubuntu, and then when I am back to OSX, the OS says it is off by hardware or something like that. How does it sound?
     
  4. ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    323
    Mobo:
    GA-P67A-UD5-B3
    CPU:
    i7 2600k @4.5 GHz
    Graphics:
    Nvidia GTX 950
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Jun 25, 2012 #4
    ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    323
    Mobo:
    GA-P67A-UD5-B3
    CPU:
    i7 2600k @4.5 GHz
    Graphics:
    Nvidia GTX 950
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Goodness...please use the search function.
    This topic is well covered. You can disable the built in bluetooth using a different kext posted in this topic

    http://tonymacx86.com/viewtopic.php?f=2 ... 6&start=90

    there I found it for ya :D

    no need to destroy you bluetooth chip with tape etc... :)
     
  5. oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Jun 25, 2012 #5
    oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Thank you for your link. Correct me if I am wrong, but to the best of my knowledge, you have to rebuild kext and reboot in order (only) to disable or enable bluetooth. If it is the case, certainly it is not what I WERE TALKING ABOUT, which is turning it on/off, i.e. toggle it.
     
  6. ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    323
    Mobo:
    GA-P67A-UD5-B3
    CPU:
    i7 2600k @4.5 GHz
    Graphics:
    Nvidia GTX 950
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Jun 25, 2012 #6
    ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    323
    Mobo:
    GA-P67A-UD5-B3
    CPU:
    i7 2600k @4.5 GHz
    Graphics:
    Nvidia GTX 950
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Ah. Apologies. Can't it be disabled in system preferences?
     
  7. lequibao

    lequibao

    Joined:
    Jan 6, 2012
    Messages:
    27
    Mobo:
    Mac Pro
    CPU:
    Core i7 930
    Graphics:
    Geforce GTX 680
    Mobile Phone:
    iOS
    Jun 25, 2012 #7
    lequibao

    lequibao

    Joined:
    Jan 6, 2012
    Messages:
    27
    Mobo:
    Mac Pro
    CPU:
    Core i7 930
    Graphics:
    Geforce GTX 680
    Mobile Phone:
    iOS
    here, the activate box is checked and it's gray, i can't deselect, so my bluetooth (that is in same card as wifi) keeps on.
    waiting for a suggestion...
     
  8. oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Jun 26, 2012 #8
    oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    I indeed don't know what your SP looks like, but my SP is just as the same as lequibao's
    PS: Chào b?n B?o!
     
  9. riodoro1

    riodoro1

    Joined:
    Oct 18, 2011
    Messages:
    196
    Mobo:
    ProBook 4530s
    CPU:
    i3 2310M
    Graphics:
    HD3k & Radeon 6450M
    Mobile Phone:
    iOS
    Jun 26, 2012 #9
    riodoro1

    riodoro1

    Joined:
    Oct 18, 2011
    Messages:
    196
    Mobo:
    ProBook 4530s
    CPU:
    i3 2310M
    Graphics:
    HD3k & Radeon 6450M
    Mobile Phone:
    iOS
    @UP, well mine too, we are glad that the bluetooth wors at all, but we yet (i hope) can't turn it or/off on a working system.

    Does toggling bluetooth visibility solve your problem ? headset should not pick up "hidden" bluetooth :)

    Here is my pref panel for bt, try un-ticking "Discoverable"
     

    Attached Files:

    • 2012-06-26 08.53.10 am.png  (13.8 KB, 361 views)
  10. oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Jun 26, 2012 #10
    oradoe

    oradoe

    Joined:
    Oct 18, 2011
    Messages:
    26
    Mobo:
    10.8.0
    CPU:
    i5
    Graphics:
    HD 3000
    Oh, I did not mention, did I, that my "Discoverable" is at all time unchecked, whether I am using my bluetooth headset or not. To the best of my knowledge, "D.." is only for those who seeks to pair with our HackBook. If there are some devices already paired, it will connect unless we can uncheck the "On", not "D.."
     

Share This Page