GA X58-USB3 - i7 950

Discussion in 'User Builds' started by donw35, Jan 3, 2011.

  1. donw35

    donw35

    Joined:
    Apr 1, 2010
    Messages:
    28
    Mobo:
    Gigabyte X58-USB3
    CPU:
    I7-950
    Graphics:
    HD 5870
    Mac:
    MacBook, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Jan 3, 2011 #1
    donw35

    donw35

    Joined:
    Apr 1, 2010
    Messages:
    28
    Mobo:
    Gigabyte X58-USB3
    CPU:
    I7-950
    Graphics:
    HD 5870
    Mac:
    MacBook, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Upgraded my system over the holiday

    Specs
    X58-USB3, i7-950, 12GB 1333Mhz DDR3, Kingston 64GB SSD, nVida 9800GT, PowerMac G5 case.

    I plan to upgrade the video card next but its working and I don't do allot of gaming.

    Audio with DSDT from Database and Multibeast
    Lan from Lnx2Mac driver
     

    Attached Files:

    • 163729_1647519421384_1038873365_1749117_6291627_n.jpg  (82.1 KB, 1,355 views)
    • 163092_1647520701416_1038873365_1749122_2946031_n.jpg  (76 KB, 1,229 views)
  2. donw35

    donw35

    Joined:
    Apr 1, 2010
    Messages:
    28
    Mobo:
    Gigabyte X58-USB3
    CPU:
    I7-950
    Graphics:
    HD 5870
    Mac:
    MacBook, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Jan 19, 2011 #2
    donw35

    donw35

    Joined:
    Apr 1, 2010
    Messages:
    28
    Mobo:
    Gigabyte X58-USB3
    CPU:
    I7-950
    Graphics:
    HD 5870
    Mac:
    MacBook, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    I have been asked what options I selected on this system so I thought I would post it.

    Note that this guide includes the Radeon HD5870 that I upgraded to

    IBoot - MultiBeast - 10.6.6

    Gigabyte GA-X58-USB3, i7-950, 12GB 1333Mhz Ram, Sapphire Radeon HD5870

    Other Devices
    Dlink-DBT120 BlueTooth adapter,

    Latest iBoot CD, Retail SL DVD, Latest MultiBeast, Combo update 10.6.6, DSDT from database.

    BIOS Settings and System config is all documented and will not be covered here.

    Boot with IBoot CD
    Install Snow Leopard Retail DVD (buy it, don't be cheap)
    Once is finished restart and boot with iBoot CD
    Do all the OS questions and what not
    install Combo update 10.6.6 but do not restart
    Copy DSDT to desktop
    Run MultiBeast
    Select UserDSDT Install
    Select Drivers & Bootloaders / Audio / Realtek ALC8xx / ALC8xxHDA and AppleHDA RollBack
    Select Miscellaneous / USB 3.0 - NEC/Renesas
    Select Network / Realtek Gigabit Ethernet / RealtekR1000SL
    Select Bootloaders / Chameleon 2.0 RC5 - ATI Experimental
    Select Boot Options / 64-Bit Apple Boot Screen
    Select System Definitions / Mac Pro / MacPeo 4.1
    Select Themes / tonymacx86 Remix
    Select OSx86 / Kext Helper b7, Kext Utility, MSR Tools

    Click Continue, Click Install, Authenticate

    Eject CD, Eject thumbdrive

    Reboot

    Note:
    After install LAN did not work, install Lnx2Mac RTL81xx Driver and reboot

    What Works: what I tested
    Video = dual 24" Monitors both DVI outputs, have not test HDMI or DP yet
    Audio = Stereo output
    Sleep = Working
    USB3 = Working but I do not have a USB3 device.


    Benchmarks
    Geekbench = 9444
    CineBench 11.5 = OpenGL 26.12fps, CPU = 5.57
     
  3. Hartmannks

    Hartmannks

    Joined:
    Jan 19, 2011
    Messages:
    1
    Mobo:
    Mac Pro
    CPU:
    3.24 GHz Intel Core i7
    Graphics:
    GeForce GT 240 512 MB
    Jan 19, 2011 #3
    Hartmannks

    Hartmannks

    Joined:
    Jan 19, 2011
    Messages:
    1
    Mobo:
    Mac Pro
    CPU:
    3.24 GHz Intel Core i7
    Graphics:
    GeForce GT 240 512 MB
    What DSDT file did you use for the install? I was not able to find a aml file for GA-X58-USB3 in the DSDT database. I found a generic dsl file that would not compile.
     
  4. MacMan

    MacMan Administrator Staff Member

    Joined:
    Feb 2, 2010
    Messages:
    7,500
    Mobo:
    GA-Z77X-UP5 TH
    CPU:
    Core i7-3770K
    Graphics:
    GTX 670
    Mac:
    MacBook Pro
    Classic Mac:
    Power Mac, PowerBook
    Mobile Phone:
    iOS
    Jan 19, 2011 #4
    MacMan

    MacMan Administrator Staff Member

    Joined:
    Feb 2, 2010
    Messages:
    7,500
    Mobo:
    GA-Z77X-UP5 TH
    CPU:
    Core i7-3770K
    Graphics:
    GTX 670
    Mac:
    MacBook Pro
    Classic Mac:
    Power Mac, PowerBook
    Mobile Phone:
    iOS
    There is one in the database, it's just before the GA-X58A-UD3R.
     
  5. edgbasto

    edgbasto

    Joined:
    Jun 4, 2011
    Messages:
    1
    Jun 9, 2011 #5
    edgbasto

    edgbasto

    Joined:
    Jun 4, 2011
    Messages:
    1
    I use the DSDT file for the BIOS F2..unfortunately updated BIOS version to F3..it doesnt work for me
     
  6. Khan

    Khan

    Joined:
    Sep 18, 2010
    Messages:
    696
    Mobo:
    GA X58A-UD7
    CPU:
    I7 3,2 Ghz
    Graphics:
    XFX ATI 6870
    Mac:
    Mac Pro
    Classic Mac:
    Classic, Power Mac, PowerBook, Workgroup Server
    Mobile Phone:
    Android, iOS
    Jun 29, 2011 #6
    Khan

    Khan

    Joined:
    Sep 18, 2010
    Messages:
    696
    Mobo:
    GA X58A-UD7
    CPU:
    I7 3,2 Ghz
    Graphics:
    XFX ATI 6870
    Mac:
    Mac Pro
    Classic Mac:
    Classic, Power Mac, PowerBook, Workgroup Server
    Mobile Phone:
    Android, iOS
    If you did a DSDT install just check ALC8xxxHDA in MultiBeast and repair permissions. No need to yell ...
     
  7. emches

    emches

    Joined:
    Jun 29, 2011
    Messages:
    16
    Mobo:
    macbook pro
    CPU:
    intel core 2 duo
    Graphics:
    nvidia 8800
    Jul 2, 2011 #7
    emches

    emches

    Joined:
    Jun 29, 2011
    Messages:
    16
    Mobo:
    macbook pro
    CPU:
    intel core 2 duo
    Graphics:
    nvidia 8800
    Heres my build. I forgot I even had windows on my computer cause I've been so immersed with this awesome OS.

    Edit: For some reason 2 of images are rotated after they are attached to the post.

    IMG_0781.JPG
    IMG_0780.JPG
    IMG_0779.JPG
     

    Attached Files:

    • IMG_0779.JPG  (1.7 MB, 725 views)
    • IMG_0780.JPG  (1.9 MB, 707 views)
  8. clarkkent08

    clarkkent08

    Joined:
    Oct 28, 2010
    Messages:
    27
    Mobo:
    Hack
    CPU:
    i7 950
    Graphics:
    XFX HD5770
    Jul 22, 2011 #8
    clarkkent08

    clarkkent08

    Joined:
    Oct 28, 2010
    Messages:
    27
    Mobo:
    Hack
    CPU:
    i7 950
    Graphics:
    XFX HD5770
    Anyone had any luck with 10.7 lion on this system?
     
  9. gregsqueeb

    gregsqueeb

    Joined:
    Jun 3, 2010
    Messages:
    17
    Mobo:
    Lion
    CPU:
    i7-1366
    Graphics:
    GTX 260
    Jul 23, 2011 #9
    gregsqueeb

    gregsqueeb

    Joined:
    Jun 3, 2010
    Messages:
    17
    Mobo:
    Lion
    CPU:
    i7-1366
    Graphics:
    GTX 260
    I am trying to get snow leopard running but I keep on getting PCI Configuration Begin error. Does anyone know how to fix this?
     
  10. wilney22

    wilney22

    Joined:
    Feb 21, 2011
    Messages:
    1
    Mobo:
    intel i7
    CPU:
    i7
    Graphics:
    i7
    Dec 9, 2011 #10
    wilney22

    wilney22

    Joined:
    Feb 21, 2011
    Messages:
    1
    Mobo:
    intel i7
    CPU:
    i7
    Graphics:
    i7
    Try npci=0x2000 at chameleon boot screen!
     

Share This Page