1. Join Date
    Sep 2012
    Posts
    13
    System
    Asrock X79 extreme4
    CPU
    i7 3820
    Graphics
    MSi Nvidia GeForce GTX 660 Twin Frozr III
    Online
    lerenoamp is offline
    #1

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Following ksosx86's thread on his X79 Extreme4 build I've got Unibeast on my USB stick, and replaced the 'Extra' folder with the Unibeast Extra.zip folder he kindly attached (so I don't have to disable multiple cores / hyperthreading etc.)

    For some reason it hangs almost immediately when I try to run the Unibeast install. Using verbose I can see the problem is 'Mac OS Version not yet set'.

    Not something I expected, most people seem to hit upon this issue post install, not prior to install.

    I'm a total newbie so there could be something obvious I've not done, but I can't figure it out.

    My system is stripped right back, ASRock Extreme X79 mobo, Intel i7 3820, XFX NVIDIA GEFORCE 9400GT, 16GB DDR3 RAM, SanDisk SATAIII SSD. Microsoft 800 Wireless Keyboard and mouse. Nothing else connected.

    Any thoughts? Any tips / things to try would be much appreciated. I'm soldiering on in the dark at present.

    Best Regards

    lernoamp

  2. Join Date
    Aug 2012
    Posts
    984
    System
    Asus P6X58D Premium
    CPU
    i7-920
    Graphics
    GTX660
    Online
    rlf156 is offline
    #2

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    The Extra folder contained a special set of kexts that allow you to boot with fewer problems. You deleted those when you replaced the Extra folder. A common problem for an Asus is to have a kernel panic on the AppleIntelCPUPowerManagement.kext. The Extra folder contained a kext named NullCPUPowerManagement.kext that would have fought that panic.

    I would suggest you remake the Unibeast USB drive and use it as built. Even if it means a couple of BIOS edits right now.

    If you get the kernel panic again, boot in verbose mode (-v) and when the text stops scrolling, snap a picture and post it.

  3. Join Date
    Aug 2012
    Posts
    984
    System
    Asus P6X58D Premium
    CPU
    i7-920
    Graphics
    GTX660
    Online
    rlf156 is offline
    #3

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    I downloaded the Extra folder from that tutorial and it has the NullCPUPowerManagement.kext inside it. So that wasn't the problem.

    And I see you have an Asrock board, not an Asus.

  4. Join Date
    Sep 2012
    Posts
    13
    System
    Asrock X79 extreme4
    CPU
    i7 3820
    Graphics
    MSi Nvidia GeForce GTX 660 Twin Frozr III
    Online
    lerenoamp is offline
    #4

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Thanks rlf156 - yes, ASRock, not Asus.

    I tried using the unmodified installer anyway, here is something you may find interesting.

    Just after the point I have taken the photo, my screen goes into power saving mode.

    However, the light on my usb stick continues to flash occasionally suggesting that the machine still working away, I just can't see what it's saying / doing.

    Although I never caught it with the photo I'm quite sure the last line before the screen shut off was IOBluetoothHCIController Start Completed.


    So, to summarise - with unmodified Extra folder screen goes blank so I can't see the last command line, with modified Extra folder, 'Mac OS Version not yet set'

    And to let you know - it is the VGA connection i have my monitor on, not the DVI or HDTV outs.
    Attached Thumbnails Attached Thumbnails ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!-20121025_221329.jpg  

  5. Join Date
    Aug 2012
    Posts
    984
    System
    Asus P6X58D Premium
    CPU
    i7-920
    Graphics
    GTX660
    Online
    rlf156 is offline
    #5

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Try booting with the following flags:

    -v -x PCIRootUID=0 cpus=1
    -v -x PCIRootUID=1 cpus=1

  6. Join Date
    Sep 2012
    Posts
    13
    System
    Asrock X79 extreme4
    CPU
    i7 3820
    Graphics
    MSi Nvidia GeForce GTX 660 Twin Frozr III
    Online
    lerenoamp is offline
    #6

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Hate to be ignorant, but with Unibeast I can't see how to enter text - only select options such as boot in verbose mode, ignore cache etc.

    How do I enter these commands in Unibeats, and how do I 'carriage return' rather than run the command when I press the return key? (Shift+Return is my guess)

    Thanks

  7. Join Date
    Aug 2012
    Posts
    984
    System
    Asus P6X58D Premium
    CPU
    i7-920
    Graphics
    GTX660
    Online
    rlf156 is offline
    #7

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    When you are booted with Unibeast and the Tonymac red apple logo is at the top, just type. It will appear in a field on the screen.

    Don't type both lines of boot flags at once. Type one line and boot with it. If it doesn't boot, try the 2nd line.

  8. Join Date
    Sep 2012
    Posts
    13
    System
    Asrock X79 extreme4
    CPU
    i7 3820
    Graphics
    MSi Nvidia GeForce GTX 660 Twin Frozr III
    Online
    lerenoamp is offline
    #8

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Thanks for that.

    Using either boot flag, no difference. I filmed it this time to catch the very last line before the screen goes into power saving mode.

    It hangs for a few seconds on the 'BootCashControl : Unable to open /var/db/BootCache.playlist' line

    Then the line that comes up immediately before screen blank is

    ACPI_SMC_PlatformPlugin::start - WaitForService(Resourcematching(Apple


    that's all I caught.

  9. Join Date
    Aug 2012
    Posts
    984
    System
    Asus P6X58D Premium
    CPU
    i7-920
    Graphics
    GTX660
    Online
    rlf156 is offline
    #9

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Go into BIOS and verify these settings:

    limit CPUID max - disable
    execute disable bit - enable
    intel virtual - enable
    vt-d - disable

  10. Join Date
    Aug 2012
    Posts
    984
    System
    Asus P6X58D Premium
    CPU
    i7-920
    Graphics
    GTX660
    Online
    rlf156 is offline
    #10

    ASRock Extreme4 X79 - 'Mac OS Version not yet set' - I'm stumped!


    Quote Originally Posted by rlf156 View Post
    Go into BIOS and verify these settings:

    limit CPUID max - disable
    execute disable bit - enable
    intel virtual - enable
    vt-d - disable
    I pulled the manual from Asrock and found 3 of those 4 settings:

    Advanced -> CPU Configuration -> No Execute Memory Protection -> Enable
    Advanced -> CPU Configuration -> Intel Virtualization Technolgy -> Enable
    Advanced -> Northbridge Configuration -> Intel VT for Directed I/O Configuration -> Intel VT-d -> Disable


    Also, don't forget that until you update with the other kexts in the tutorial, you should boot with (as a minimum): -v cpus=1

  11. Similar Threads:

Page 1 of 2 12 Last

Tags for this Thread