1. Join Date
    Apr 2012
    Posts
    10
    Online
    sulliwane is offline
    #1

    DELL XPS L501X - Bios A8 - MacOSX LION 10.7.3


    Hello there, hi everybody

    i'm stuck with my hackintosh trying to install OSX LION 10.7.3 on my XPS L501X.

    1- I created a bootable usb stick from my Macbookpro (appstore/laptop option with unibeast)
    2- i booted on it pressing "C" key with the mac
    3- i choose to install MacOSX Lion on an USB Hard Drive
    4- the installation went well, i booted on the Usb HardDrive => No problem ! I succeed to launch MacOSX from the usb HDD.
    5- opened Multibeast, checked the box to make my HDD bootable

    Here I am with a proper and bootable install of MacOSX LION on a HDD. Now, if i put the HDD in my DELL XPS L501X, it boots on the HDD, but the process keeps stuck on the booting loading image of MacOSX...

    Tried some "-v GraphicsEnabler=No busratio=20 arch=i386 -x32" and i get stuck on boot as you can see on the image attached.

    Does somebody has a solution in mind ?

    Thanks a lot

    cheers from france

    ps : attached my stock sdst.aml extracted from win7 with DSDTE
    Attached Thumbnails Attached Thumbnails DELL XPS L501X - Bios A8 - MacOSX LION 10.7.3-bootosx.jpg  
    Attached Files Attached Files

  2. Join Date
    Apr 2012
    Posts
    10
    Online
    sulliwane is offline
    #2

    Re: DELL XPS L501X - Bios A8 - MacOSX LION 10.7.3


    Hey, thanks for you answer.

    Yes I tried the -x flag, but still an error in the booting process.

    I must precise that I neither modified my dsdt.aml nor added some extra/extensions folder.

    But do you think this is the issue ? Should I edit the dsdt.aml and if yes, in which way ?

    Using Multibeaset/easybeast is useless because I can boot only from the Mac (not from my DELL)

    Thank you

  3. Join Date
    Apr 2012
    Posts
    10
    Online
    sulliwane is offline
    #3

    Re: DELL XPS L501X - Bios A8 - MacOSX LION 10.7.3


    I think that adding some specs might be better !

    So, from Ubuntu, I exctracted my DSDT.aml, decompiled it (DSDT.dsl), and cat a lspci.txt with the details of my xps specs.

    maybe it helps ?

    Thx

    Code:
    Bios vers: A08	07/26/2011
    CPU Version 2530 MHz CPU-model 37
    =====================================================
    Bus info          Périphérique  Classe         Description
    pci@0000:02:00.0                  display        NVIDIA Corporation [10DE:0DF1]
    pci@0000:00:02.0                  display        Core Processor Integrated Graphics Controller [8086:0046]
    
    pci@0000:00:1f.2  scsi0           storage        5 Series/3400 Series Chipset 6 port SATA AHCI Controller [8086:3B2F]
    usb@3:1           scsi6           storage        
    usb@3:2           scsi7           storage        
    
    pci@0000:00:1b.0                  multimedia     5 Series/3400 Series Chipset High Definition Audio [8086:3B56]
    
    pci@0000:04:00.0  wlan1           network        Centrino Wireless-N 1000 [8086:0083]
    pci@0000:09:00.0  eth2            network        RTL8111/8168B PCI Express Gigabit Ethernet controller [10EC:8168]
    
    pci@0000:00:1a.0                  bus            5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3B3C]
    pci@0000:05:00.0                  bus            uPD720200 USB 3.0 Host Controller [1033:0194]
    pci@0000:00:1d.0                  bus            5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3B34]
    pci@0000:00:1f.3                  bus            5 Series/3400 Series Chipset SMBus Controller [8086:3B30]
    =====================================================
    Attached Files Attached Files

  4. Similar Threads: