Contribute
Register

Triple Boot Maverick, Win 8, Linux Mint

Status
Not open for further replies.
Joined
Nov 14, 2012
Messages
31
Motherboard
Asus P8Z77-V LX
CPU
i7-3770K
Graphics
GeForce GTX 660
Mac
  1. 0
Classic Mac
  1. 0
Mobile Phone
  1. 0
The following is a summary of my successful triple boot installation with Maverick, Win 8 and Linux Mint.

Since Linux creates the biggest headache, this guide is a bit more detailed on that section.

My Hardware:
SSD OS X
SSD Win 8
SSD Linux Mint
HDD Data

Goal

We want that Chimera only displays three boot options: OS X, Win 8 and Linux
We do not want that OS X complains: “The disk you inserted was not readable by this computer”

here we go...


Install OS X
Connect the SSD OS X to the mother board.
Follow the OS X installation guidelines in this forum and install Chimera via MultiBeast.


After the OS X installation log out and switch off the PC.


Install Windows
Switch off the PC disconnect the SSD OS X.
With only SSD Win 8 connected to the mother board install Windows.


Find in Windows under system settings the option where you can format your HDD (it took me 10min to find it and forgot how I got there).


Change the volume names “System Reserved” to “Windows” and the other windows partition to “Win8”


Explanation:
This is in preparation for Chimera to display sensible strings under the icons.


After reboot Chimera should display OS X, Windows and Win8 icons.


Prepare a Linux Mint USB stick
Load OS X
Download Linux Mint (google is your friend)
Drag the Linux Mint iso file to the desktop (makes the following easier)
Rename the file to linuxmint.iso


Open the Terminal and enter the following commands in italic:


Convert iso to img
hdiutil convert -format UDRW -o ~/Dektop/linuxmint.img ~/Dektop/linuxmint.iso


Rename linuxmint.img.dmg to linuxmint.img by just clicking on the file.


Get current devices:
diskutil list


Insert an USB stick (4 GB is more than enough)


Run diskutil list again and determine the device node ‘N’ assigned to your USB stick (e.g. /dev/disk2).


Unmount the USB stick (replace the N with the device number from above)
diskutil unmountDisk /dev/diskN


Put the linuxmint.img file to the USB stick (replace the N)
sudo dd if=/Desktop/linuxmint.img of=/dev/rdiskN bs=1m


Eject the USB stick (replace the N)
diskutil eject /dev/diskN




Install Linux Mint
Switch of the PC
Disconnect SSD OS X, SSD Win and HDD data
Connect SSD Linux
Repower the PC and boot Linux from USB stick (how to do it depends on you board, this forum or google are your friends)


When the Linux Mint desktop appears double click on Install Linux Mint
When you arrive at the window “Installation Type” select “Something else” and click “Install now”
That following “Installation Type” window shows a table. Most likely in the Device column you have an entry /dev/sda. Select it and click “New Partition Table…”
By pressing the (+) button add the following partitions (the MB’s are an example):


a) Dummy partition: FAT32 100 MB (we do not need more)
b) Linux Root (/): Ext4 10720 MB
c) Linux Swap: Ext 4 21440 MB (as a minimum size of RAM)
d) Linux Home (/home): Ext4 10720 MB
e) Linux User (/usr/local): Ext4 21440 MB (the remaining space of the HDD)


Device for boot loader installation:
f) Select from the drop down that it points to the Linux Root (/)


Explanation:
a) prevents OS X to show the ignoring message after boot: “The disk you inserted was not readable by this computer”. This partition must be FAT32 formatted and must be the first partition.
f) enables Chimera to find the Linux boot loader


Finalize the Linux installation and close Linux.
Switch off the PC and rewire all HDDs.
Reboot
Chimera now displays OSX, Linux, Windows and a couple of more icons. We suppress the unnecessary icons in the next step. Write down the position of icons you do NOT want to get displayed.


Hide Partitions in Chimera
Load OS X
Find via Spotlight the file: org.chameleon.Boot.plist and load it into a text editor.


You have two options to suppress a partition in Chimera, by string or hd() reference. I got rid of my unwanted partitions by adding:
<key>Hide Partition</key>
<string>"UNUSED" "Win8" hd(1,1)</string>


But, there might be a downside. On my system DiskUtilities hangs when I suppress partitions.


BINGO DONE


Up to now I failed to suppress the devices of Win8 in OS X under Finder Devices. I do not need access to them from OS X and therefore I do not want them to show-up.
 
:clap: good

I would have used the Live Linux Mint download instead of the multistep creation of the USB installer. It is much easier.
 
Prevent NTFS or FAT32 volumes from being mounted in OSX
By default OSX mounts all HDD devices, which it can find and read. The devices are then shown in Finder under Devices and are accessible. In a multi boot environment that is not necessarily what you want.


The key to tell OSX not to mount specific volumes is /etc/fstab which is not included in OSX by default.
What we need:
1) The volume names of devices which shall not be mounted
2) The filesystem format
3) create /etc/fstab


On my system I have three volumes which shall not be mounted:
Windows
Win8System
UNUSED


Open the Terminal in OSX and type the italic lines:


Check the filesystem format
diskutil info /Volumes/'<YourVolumeName>'

Example: diskutil info /Volumes/'Windows'


The output gives you under File System whether the volume is FAT32 or NTFS.


In Terminal create fstab:
sudo tee -a /etc/fstab


Add content to /etc/fstab:


For FAT32 type in Terminal:
LABEL=<YourVolumeName> none msdos rw,noauto 0 0


For NTFS type in Terminal:
LABEL=<YourVolumeName> none ntfs rw,noauto 0 0


Press "Ctrl+D" to close the tee application and write to file.


Check fstab with:
cat /etc/fstab


My fstab looks like this:
LABEL=Windows none ntfs rw,noauto 0 0
LABEL=Win8System none ntfs rw,noauto 0 0
LABEL=UNUSED none ntfs rw,noauto 0 0


BINGO DONE


Next time you boot OSX, the specified volumes will not be mounted
 
Prevent NTFS or FAT32 volumes from being mounted in OSX
By default OSX mounts all HDD devices, which it can find and read. The devices are then shown in Finder under Devices and are accessible. In a multi boot environment that is not necessarily what you want.


The key to tell OSX not to mount specific volumes is /etc/fstab which is not included in OSX by default.
What we need:
1) The volume names of devices which shall not be mounted
2) The filesystem format
3) create /etc/fstab


On my system I have three volumes which shall not be mounted:
Windows
Win8System
UNUSED


Open the Terminal in OSX and type the italic lines:


Check the filesystem format
diskutil info /Volumes/'<YourVolumeName>'

Example: diskutil info /Volumes/'Windows'


The output gives you under File System whether the volume is FAT32 or NTFS.


In Terminal create fstab:
sudo tee -a /etc/fstab


Add content to /etc/fstab:


For FAT32 type in Terminal:
LABEL=<YourVolumeName> none msdos rw,noauto 0 0


For NTFS type in Terminal:
LABEL=<YourVolumeName> none ntfs rw,noauto 0 0


Press "Ctrl+D" to close the tee application and write to file.


Check fstab with:
cat /etc/fstab


My fstab looks like this:
LABEL=Windows none ntfs rw,noauto 0 0
LABEL=Win8System none ntfs rw,noauto 0 0
LABEL=UNUSED none ntfs rw,noauto 0 0


BINGO DONE


Next time you boot OSX, the specified volumes will not be mounted

This is good information.

What if the volume name contains a space like 'Windows 7' instead of just 'Windows' or 'Win8System'. Do we use single quotes like :

LABEL='Windows 7'

Or double quotes like :

LABEL="Windows 7"

Or something else ?
 
This is good information.

What if the volume name contains a space like 'Windows 7' instead of just 'Windows' or 'Win8System'. Do we use single quotes like :

LABEL='Windows 7'

Or double quotes like :

LABEL="Windows 7"

Or something else ?

Been awhile, but IIRC the space becomes a \ , so with the space it would be Label='Windows\7'
 
But my Linux drive has no name to put in the /fstab. I cant use LABEL= . I'm sure there is someone who has Linux and has fond a way to hide the Linux drives.
 
But my Linux drive has no name to put in the /fstab. I cant use LABEL= . I'm sure there is someone who has Linux and has fond a way to hide the Linux drives.

Are you able to see the Linux drive in Windows explorer?

Right Click on drive letter in WE. select properties, click in box at top of window next to the drive icon and type in a name like Linux or Ubuntu or whatever you want to call it. That would take care of that problem.
 
With this method is it possible to have the boot loader automatically start booting into OS X unless stopped by the pressing of a key on the keyboard? This is how my setup currently works with OS X and Windows 7, and I'm wanting to add Linux Mint using the method described above, but don't want the boot loader to pause unless I deliberately pause it as OS X will still be what I use by far the most out of the three OSes.
 
With this method is it possible to have the boot loader automatically start booting into OS X unless stopped by the pressing of a key on the keyboard? This is how my setup currently works with OS X and Windows 7, and I'm wanting to add Linux Mint using the method described above, but don't want the boot loader to pause unless I deliberately pause it as OS X will still be what I use by far the most out of the three OSes.

Adding Linux distro will not change the current action of your Chimera boot loader. It will just add an icon which will appear when you hit a key during the timeout period as you do now for Windows.
 
Status
Not open for further replies.
Back
Top