1. Join Date
    Jan 2012
    Posts
    18
    System
    4530s
    CPU
    i5-2430M
    Graphics
    hd3000
    Geekbench Score
    6806
    Online
    nnxwtf is offline
    Android Phone
    #1

    Clover boot


    Hello everyone:)

    I wish to open topic on Clover Bootloader.
    http://cloverefiboot.sourceforge.net

    I gave few attempts to this bootloader yesterday. I was after fixing iMessage by following later posts on topic iMessage Won't Work page 30 and so on, but it did not go with success. I now get just different error message when trying to login into iMesage.
    But so, I was able to boot with Clover.
    Using BIOS-booting (not UEFI sadly) and removed AppleIntelCPUPowerManagement.kext (got kernel panics on it, otherwise, but so it disabled sleep and maybe something else). System and booting process looked kind of snappier a bit.


    If anyone have tried, how did it go ?
    Did you get UEFI booting to work ?
    What other experiences?

    Thanks.
    4530s: Core i5 (2430M); 8Gb; OSX 10.9;

  2. Join Date
    Mar 2011
    Posts
    255
    System
    ProBook 4530s
    CPU
    i5-2410
    Graphics
    HD3000
    Online
    faithie999 is offline
    #2

    Clover boot


    i had the same KP when i tried to boot from a clover USB stick (i didn't want to install clover to my HD until i knew it would work).

    did you try reverting to the non-patched-for-mountain lion version of applecpupowermanagement.kext before you removed it altogether? not sure it would make any difference.

    i assume sooner or later the chimera team will come up with a solution so we don't need to switch to clover.

  3. Join Date
    Jun 2012
    Posts
    13
    System
    Gigabyte H55 USB3
    CPU
    i3 3.0Ghz
    Graphics
    Radeon 5770
    Online
    shmerek is offline
    iPhone
    #3

    Clover boot


    I gave it a go using the guide here http://www.insanelymac.com/forum/top...es-fix-how-to/ but I couldn't get it to boot, kept getting a kernel panic related to the AppleIntelCPUPowerManagement.kext. I tried it with the vanilla version as well but still no luck. I don't know if I am screwing something up with the install but I just couldn't get it working.
    GA-H55M-USB3 F10 Core i3 Gigabyte Radeon 5770HD

  4. Moderator
    Other  
    Join Date
    May 2012
    Posts
    46,135
    System
    Intel DH67BL/HP ProBook 4530s (Clover)
    CPU
    Core i7-2600K/Core i3-2310m
    Graphics
    Intel HD 3000
    Geekbench Score
    11641
    Online
    RehabMan is offline
    iPhone MacBook Air
    #4

    Clover boot


    Quote Originally Posted by nnxwtf View Post
    Hello everyone

    I wish to open topic on Clover Bootloader.
    http://cloverefiboot.sourceforge.net

    I gave few attempts to this bootloader yesterday. I was after fixing iMessage by following later posts on topic iMessage Won't Work page 30 and so on, but it did not go with success. I now get just different error message when trying to login into iMesage.
    But so, I was able to boot with Clover.
    Using BIOS-booting (not UEFI sadly) and removed AppleIntelCPUPowerManagement.kext (got kernel panics on it, otherwise, but so it disabled sleep and maybe something else). System and booting process looked kind of snappier a bit.


    If anyone have tried, how did it go ?
    Did you get UEFI booting to work ?
    What other experiences?

    Thanks.
    I played around with it a bit... Some notes:

    - on the Probook, we use a Chimera module to do some EC manipulation at startup. This module resets the fan to factory upon starting Chimera and is very important to keep laptops from overheating, especially in multi-boot environments. At a minimum, I will have to port this module to Clover (no idea how to do that yet). The build process for Clover is quite complex, so figuring out how to add a driver to the process should be interesting (And I thought Chimera/Chameleon was complex).

    - So far, I can't get Clover to boot my Ubuntu 12.04LTS partition, on a restart... only from a cold boot, (not warm boot) even if the restart was from Ubuntu itself.

    - No problem booting Win7-64. Haven't tried Win8 as it is not installed on my laptop.

    - I have it booting my ML partition using BIOS mode Clover (I haven't tried Lion or SL, should be similar). I have not attempted to implement the iMessage fix part of the config.plist, as I was really just trying to get Clover to work. More testing is needed.

    - Clover on the Probook only works in BIOS mode. UEFI mode is a non-starter due to some sort of incompatibility (I think) between HP's UEFI BIOS and the HFSPlus.efi (UEFI driver for HFS+, supposedly extracted from actual Mac BIOS). I also tried running Clover on my desktop, and there it was able to properly show the HFS+ partitions (so Intel's BIOS is probably compatible with HFSPlus.efi). It is possible this could be the case with more than just the Probook, where UEFI implementations don't provide what is needed or are otherwise half-baked.

    - I had to use DropOemSSDT and place my SSDT.aml and patched DSDT.aml into /EFI/ACPI/patched

    - UEFI Clover can recognize both Win7 and Ubuntu partitions but cannot boot them. Bottom line: I can't boot anything with UEFI Clover, but BIOS mode Clover can boot 2 of 3 (and from cold boot 3 of 3).

    - Some of the selections in Clover lead to Chimera on my system (must be loading MBR and executing). There is probably a way to hide these.

    - All my testing was using a USB stick. It is not worth it to risk a stable Chimera setup by messing with your main HDD/SSD.
    Laptop#1: (Clover) HP ProBook 4540s D8C12UT (1080p), i5-3230m, BIOS F.50a: OS X 10.10/Windows 7/Windows 8.1
    Laptop#2: (Clover) Lenovo U430 Touch, i7-4500U: OS X 10.10/Windows 8.1
    Desktop: (Clover) DIY Intel DH67GD, Core i7-2600K, Dell U3011+U2001FP: 10.10/10.7.5/Windows 8.1/Windows 10(TP)
    Projects || Blog

  5. Join Date
    Nov 2010
    Posts
    1,010
    System
    MSI Z77MA-G45
    CPU
    i7-3770k @ 4.3 GHz
    Graphics
    PowerColor 6870 mDP
    Geekbench Score
    16855
    Online
    ersterhernd is offline
    iPhone MacBook Mac Mini PowerMac
    #5

    Clover boot


    I created a USB stick with Clover on it and put my patched DSDT and SSDT in the /EFI/ACPI/patched folder. It fixed iMessage, just as it did on my desktop Hack. Unfortunately upon reboot using the normal bootloader, the iMessage interface shows as inactive again and won't log in properly. On the PC, a normal reboot shows iMessage as logged in and usable.

    Will be interesting to see this develop into a fix for the ProBook.

  6. Join Date
    Jan 2012
    Posts
    18
    System
    4530s
    CPU
    i5-2430M
    Graphics
    hd3000
    Geekbench Score
    6806
    Online
    nnxwtf is offline
    Android Phone
    #6

    Clover boot


    Quote Originally Posted by shmerek View Post
    I gave it a go using the guide here http://www.insanelymac.com/forum/top...es-fix-how-to/ but I couldn't get it to boot, kept getting a kernel panic related to the AppleIntelCPUPowerManagement.kext. I tried it with the vanilla version as well but still no luck. I don't know if I am screwing something up with the install but I just couldn't get it working.
    Booting without AppleIntelCPUPowerManagement.kext (just renamed it to "*.kext_") sorted out booting, but that's a no solution for using Clover as a default bootlaoder. Good enough for fixing Apple's Messages, though.

    Quote Originally Posted by faithie999 View Post
    did you try reverting to the non-patched-for-mountain lion version of applecpupowermanagement.kext before you removed it altogether? not sure it would make any difference.
    No, I didn't try using stock AppleIntelCPUPowerManagement.kext, didn't have back then.
    I may I give a go sometime again.


    Quote Originally Posted by RehabMan View Post

    - Clover on the Probook only works in BIOS mode. UEFI mode is a non-starter due to some sort of incompatibility (I think) between HP's UEFI BIOS and the HFSPlus.efi (UEFI driver for HFS+, supposedly extracted from actual Mac BIOS). I also tried running Clover on my desktop, and there it was able to properly show the HFS+ partitions (so Intel's BIOS is probably compatible with HFSPlus.efi). It is possible this could be the case with more than just the Probook, where UEFI implementations don't provide what is needed or are otherwise half-baked.

    - I had to use DropOemSSDT and place my SSDT.aml and patched DSDT.aml into /EFI/ACPI/patched
    Yes. Found myself in the same situation in the end.
    But still had to disable AppleIntelCPU*.kext to get it booting with BIOS mode Clover.
    Problem with UEFI is all about HFS+ drivers not being shown. Got few different drivers, but none worked.

    Quote Originally Posted by ersterhernd View Post
    I created a USB stick with Clover on it and put my patched DSDT and SSDT in the /EFI/ACPI/patched folder. It fixed iMessage, just as it did on my desktop Hack. Unfortunately upon reboot using the normal bootloader, the iMessage interface shows as inactive again and won't log in properly. On the PC, a normal reboot shows iMessage as logged in and usable.

    Will be interesting to see this develop into a fix for the ProBook.
    I couldn't even get Messages fixed once, it kept giving me error, that there's nothing wrong, but I have to call somewhere, : D


    Should I call it, maybe?
    Apple will know my number then. : D
    4530s: Core i5 (2430M); 8Gb; OSX 10.9;

  7. Moderator
    Other  
    Join Date
    May 2012
    Posts
    46,135
    System
    Intel DH67BL/HP ProBook 4530s (Clover)
    CPU
    Core i7-2600K/Core i3-2310m
    Graphics
    Intel HD 3000
    Geekbench Score
    11641
    Online
    RehabMan is offline
    iPhone MacBook Air
    #7

    Clover boot


    Quote Originally Posted by nnxwtf View Post
    Booting without AppleIntelCPUPowerManagement.kext (just renamed it to "*.kext_") sorted out booting, but that's a no solution for using Clover as a default bootlaoder. Good enough for fixing Apple's Messages, though.
    Your issue with AICPM is probably because you didn't do one or both of:
    - add DropOemSSDT to config.plist
    - copy your SSDT.aml to EFI/ACPI/patched/
    Laptop#1: (Clover) HP ProBook 4540s D8C12UT (1080p), i5-3230m, BIOS F.50a: OS X 10.10/Windows 7/Windows 8.1
    Laptop#2: (Clover) Lenovo U430 Touch, i7-4500U: OS X 10.10/Windows 8.1
    Desktop: (Clover) DIY Intel DH67GD, Core i7-2600K, Dell U3011+U2001FP: 10.10/10.7.5/Windows 8.1/Windows 10(TP)
    Projects || Blog

  8. Join Date
    Nov 2011
    Posts
    8
    System
    HP ProBoor 4330s Mac OS X10.8.2 (Clover EFI)
    CPU
    Intel Core i3 2350m
    Graphics
    Intel HD3000
    Online
    Beshuta is offline
    Android Phone
    #8

    Clover boot


    Quote Originally Posted by nnxwtf View Post
    Booting without AppleIntelCPUPowerManagement.kext (just renamed it to "*.kext_") sorted out booting, but that's a no solution for using Clover as a default bootlaoder. Good enough for fixing Apple's Messages, though.
    No, I didn't try using stock AppleIntelCPUPowerManagement.kext, didn't have back then.
    I may I give a go sometime again.
    D
    I Used Clover! you need too install vanilla AppleIntelCPUPowerManagement.kext! my EFI, with config.plist
    Clover The best Bootloader! Thanks to Slice,Dmazar,Apianti,Pene,STLVNUB,BlackOSx.. and other team!!!!!!
    Attached Files Attached Files

  9. Join Date
    Jan 2012
    Posts
    18
    System
    4530s
    CPU
    i5-2430M
    Graphics
    hd3000
    Geekbench Score
    6806
    Online
    nnxwtf is offline
    Android Phone
    #9

    Clover boot


    Quote Originally Posted by RehabMan View Post
    Your issue with AICPM is probably because you didn't do one or both of:
    - add DropOemSSDT to config.plist
    - copy your SSDT.aml to EFI/ACPI/patched/
    yeah, this let me to boot finally,

    Quote Originally Posted by Beshuta View Post
    I Used Clover! you need too install vanilla AppleIntelCPUPowerManagement.kext! my EFI, with config.plist
    Clover The best Bootloader! Thanks to Slice,Dmazar,Apianti,Pene,STLVNUB,BlackOSx.. and other team!!!!!!
    using either modified or stock kext.

    in the end, clover has way more better features compared to chimera included in probook installer,
    would definitely switch to it,
    but found myself with boot1: error (none of fixes I googled worked for me), when installing clover on hdd, no probs with usb thou.
    Any thoughts on this little one?
    4530s: Core i5 (2430M); 8Gb; OSX 10.9;

  10. Join Date
    Feb 2011
    Posts
    29
    System
    Gigabyte P55-USB3
    CPU
    Intel Core i7 870 2.93 Ghz
    Graphics
    EVGA GeForce GTX 460 SE 1GB
    Online
    jmain is offline
    iPhone MacBook Air
    #10

    Clover boot


    I am attempting to use Clover on a USB stick. It boots fine (Seems faster to get to desktop then chimera) but shortly after desktop loads it reboots.
    I have my dsts installed in the patched folder. It is a gigabyte p55 USB3 MB.

    Also my onboard sound is not working. I am using the AppleHDA rollback and booting chimera audio works.

    Where should I look to see why the system is restarting?

  11. Similar Threads:

Page 1 of 9 123 ... Last