1. Join Date
    Apr 2012
    Posts
    16
    System
    GA-Z68MA-D2H-B3
    CPU
    Intel I5 2500K
    Graphics
    HD 3000
    Online
    fpolak is offline
    Phone (other)
    #1

    Help with HD3000 on mountain lion


    Hi,

    I can't install HD3000 on my system, Everything works fine (audio, Network, sleep) but graphic card still working as 64mb of graphics shared memory!!! my setup is:

    mobo GA-Z68MA-D2H-B3 rev 1.0 UEFI bios U1b
    BIOS Settings - Set "Internal Graphics Memory Size" to 480MB
    I5 2500k
    HD3000 graphics

    First I install moutain lion with unibeast method. Then I installed multibeast 5.1.3 with:

    Drivers
    Miscellaneous
    FakeSMC
    FakeSMC Plugins -> Motherboard Plugins, HWMonitor Application

    Bootleader
    Chimera v1.11.1

    Customization
    System Definitions
    Mac mini


    GraphicsEnabler=yes don´t boot. hangs system
    GraphicsEnabler=no boot, but don´t recognize graphic card

    What can be happening?

    Please help!

  2.   
    Join Date
    Jul 2012
    Posts
    99
    System
    Z68MA-D2H-B3 (UEFI BIOS)
    CPU
    Intel Core i5 (2500K) 3.30 Ghz
    Graphics
    Geforce GTX 560 Ti 1GB
    Geekbench Score
    9678
    Online
    qb84 is offline
    iPhone MacBook Pro Mac Mini
    #2

    Help with HD3000 on mountain lion


    We have the same configuration.

    I was able to make it work by editing AppleIntelHD3000Graphics.kext and AppleIntelSNBGraphicsFB.kext and replacing 0x01068086 with 0x01128086 on the Info.plist file.

    I had to boot using GraphicsEnabled=Yes and PciRoot=1 (or I either got a blank screen or dark screen).

    The PciRoot you may not need. I probably had to add it because I have another graphic card installed.

    The only thing I havent been able to get working is Airplay :(.

    Hope that helps.

  3. Join Date
    Apr 2012
    Posts
    16
    System
    GA-Z68MA-D2H-B3
    CPU
    Intel I5 2500K
    Graphics
    HD 3000
    Online
    fpolak is offline
    Phone (other)
    #3

    Help with HD3000 on mountain lion


    Thanks for your help qb84,

    I edited AppleIntelHD3000Graphics.kext and AppleIntelSNBGraphicsFB.kext but the system hangs when booting whit GraphicsEnabler=Yes and =No.

    I copied /System/Library/Extensions/AppleIntelHD3000Graphics.kext and /System/Library/Extensions/AppleIntelSNBGraphicsFB.kext to desktop. I backup them and then i edited with text edit and try to install with Kext Utility first without success and the with KextBeast.

    I received this error from system log with both methods:

    02/01/13 21:55:39,000 kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics - library kext com.apple.iokit.IOGraphicsFamily not found.
    02/01/13 21:55:39,000 kernel[0]: Can't load kext com.apple.driver.AppleIntelHD3000Graphics - failed to resolve library dependencies.
    02/01/13 21:55:39,000 kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics failed to load (0xdc00800e).
    02/01/13 21:55:39,000 kernel[0]: Failed to load kext com.apple.driver.AppleIntelHD3000Graphics (error 0xdc00800e).



    I only can boot with -v -x flags. But when OS X started I see in "About this Mac - More Information - Graphics" (Intel HD Graphics 3000 64 MB de memoria de sistema compartida)

    In System Report:

    Intel HD Graphics 3000:

    Modelo de chipset: Intel HD Graphics 3000
    Tipo: GPU
    Bus: Integrado
    VRAM (total): 64 MB de memoria de sistema compartida
    Fabricante: Intel (0x8086)
    ID del dispositivo: 0x0112
    ID de la revisión: 0x0009
    Información de la extensión del kernel: Ninguna extensión de kernel (kext) cargada
    Pantallas:
    Pantalla:
    Resolución: 1024 x 768
    Profundidad de píxel: Color de 32 bits (ARGB8888)
    Pantalla principal: Sí
    Duplicado: Desactivado
    En línea: Sí

    And this log:

    02/01/13 21:59:55,000 kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics is not loadable during safe boot; omitting its personalities.
    02/01/13 22:00:10,372 com.apple.kextd[11]: Can't load AppleIntelHD3000Graphics.kext - ineligible during safe boot.
    02/01/13 22:00:10,374 com.apple.kextd[11]: Load com.apple.driver.AppleIntelHD3000Graphics failed; removing personalities from kernel.

    Then I rollback to original kext and boot ok to write this reply.

  4.   
    Join Date
    Jul 2012
    Posts
    99
    System
    Z68MA-D2H-B3 (UEFI BIOS)
    CPU
    Intel Core i5 (2500K) 3.30 Ghz
    Graphics
    Geforce GTX 560 Ti 1GB
    Geekbench Score
    9678
    Online
    qb84 is offline
    iPhone MacBook Pro Mac Mini
    #4

    Help with HD3000 on mountain lion


    Do you have the file IOGraphicsFamily.kext under /S/L/E ?

  5. Join Date
    Apr 2012
    Posts
    16
    System
    GA-Z68MA-D2H-B3
    CPU
    Intel I5 2500K
    Graphics
    HD 3000
    Online
    fpolak is offline
    Phone (other)
    #5

    Help with HD3000 on mountain lion


    Yes i have it.

  6. Join Date
    Apr 2012
    Posts
    16
    System
    GA-Z68MA-D2H-B3
    CPU
    Intel I5 2500K
    Graphics
    HD 3000
    Online
    fpolak is offline
    Phone (other)
    #6

    Help with HD3000 on mountain lion


    Could you atacch your working kexts? Do you use chimera? Any other consideration to install mountain lion? I did clear install, then multibeast 5.1.3 with FakeSMC, chimera 1.11.1 and macmini system definition. Created org.chameleon.Boot.plist with GraphicsEnabler=No. For test I added flags to bootloader

    Thank for your help!

  7.   
    Join Date
    Jul 2012
    Posts
    99
    System
    Z68MA-D2H-B3 (UEFI BIOS)
    CPU
    Intel Core i5 (2500K) 3.30 Ghz
    Graphics
    Geforce GTX 560 Ti 1GB
    Geekbench Score
    9678
    Online
    qb84 is offline
    iPhone MacBook Pro Mac Mini
    #7

    Help with HD3000 on mountain lion


    Quote Originally Posted by fpolak View Post
    Could you atacch your working kexts? Do you use chimera? Any other consideration to install mountain lion? I did clear install, then multibeast 5.1.3 with FakeSMC, chimera 1.11.1 and macmini system definition. Created org.chameleon.Boot.plist with GraphicsEnabler=No. For test I added flags to bootloader

    Thank for your help!
    I didn't do anything special to install ML. I may be wrong but it should be GE=Yes. I would boot with -f as well. A lot of the times it was enough to let me boot and fix permissions, etc. Right now I'm using Chameleon but the HD3000 gpu was working with Chimera as well on my system.

    I added my boot file as well.
    Attached Files Attached Files

  8. Join Date
    Apr 2012
    Posts
    16
    System
    GA-Z68MA-D2H-B3
    CPU
    Intel I5 2500K
    Graphics
    HD 3000
    Online
    fpolak is offline
    Phone (other)
    #8

    Help with HD3000 on mountain lion


    I will try it in a few hours. If it fail, Do you recomend a clean install of ML?

  9. Join Date
    Apr 2012
    Posts
    16
    System
    GA-Z68MA-D2H-B3
    CPU
    Intel I5 2500K
    Graphics
    HD 3000
    Online
    fpolak is offline
    Phone (other)
    #9

    Help with HD3000 on mountain lion (NEW PROBLEM)


    Finally my mac works with full resolution, but without QE/CI.

    The method is describe below:

    1. Delete all graphics kexts (AppleIntelHD3000, AppleIntelHD4000, AppleIntelHDGraphics, NVIDIA, ATI, GeForce, Natit, NVDAGF100Hal, NVDAResman) etc.

    2. Repair permissions, rebuild cache (use kext wizard).

    3. Install attached kexts. https://www.dropbox.com/s/v3ybzzh2snb6wcs/HD3000.zip

    4. Repair permissions, rebuild cache (use kext wizard).

    5. Restart.


    Mac recognized HD3000 as 512mb VRAM instead of just 384mb configured in bios. Now I'm working with 1366x768 resolution, dvd player works, Diablo III works with full resolution, but I don't have desktop's icons animated.

    Anyone got similar issues?

  10. Join Date
    Aug 2011
    Posts
    4
    System
    Sony Vaio AR41E
    CPU
    Intel Core 2 Duo 1,86 GHz
    Graphics
    nivida Geforce 8400M GT
    Online
    hintzsche is offline
    #10

    Help with HD3000 on mountain lion


    is there no way to get fully support of the hd 3000? when i delete any grafics kext i get kernal panic because geforce cant load something.

  11. Similar Threads:

Page 1 of 2 12 Last