• UniBeast 2.0 Update


    56
    Published on 06-25-2013 12:30 PM by
    UniBeast has been updated to version 2.0. Starting with this release there will be only one unified version for any Mac App Store purchased copy of OS X. This new version supports OS X Lion and Mountain Lion, and will be updated to support Mavericks upon its official release. UniBeast 2.0 is now available for download at tonymacx86.com/downloads.

    Changes:
    • Single version for Lion or Mountain Lion
    • Bootloader updated to Chimera 2.1.1 r2148
    • FakeSMC updated to 5.1.67 by kozlek
    • Intel Ethernet driver (AppleIntelE1000e) updated to 2.3.2 by hnak
    • USB 3.0 support added using GenericUSBXHCI 1.2.4 by zenith432
    • UniBeast will now auto discover available Mac App Store versions of OS X, however it will only allow the use of one. If desired, select the Laptop and/or Legacy USB option(s) before selecting OS X version.

    Please do not upload or redistribute UniBeast to any other sites.

    If this utility has helped you, please consider a contribution to support further UniBeast development. Thanks in advance, and enjoy!

    Related Posts:
    Installation Guide - OS X 10.8 - UniBeast for Mountain Lion
    Installation Guide - OS X 10.7 - UniBeast for Lion
    UniBeast Troubleshooting Notes
    UniBeast.com
    Comments 56 Comments
    1. sirretv's Avatar
      sirretv -
      Nice!!! keep up the good job! Could you guys just clearify "
      USB 3.0 support added using GenericUSBXHCI 1.2.4 by zenith432"
      Thanks!
      -Sirretv
    1. MacMan's Avatar
      MacMan -
      The new UniBeast includes USB 3 support by including by default the
      GenericUSBXHCI kext by zenith432.
    1. osxmix's Avatar
      osxmix -
      USB 3.0 ... YA ... Faster !!!
    1. Craigrox's Avatar
      Craigrox -
      Nice new logo?
    1. jamesahaulic's Avatar
      jamesahaulic -
      Amazing. Thanks everyone for all the hard work!
    1. Gordo74's Avatar
      Gordo74 -
      So does this work for Mavericks now for those of us with a Developer account?
    1. tonymacx86's Avatar
      tonymacx86 -
      Quote Originally Posted by Gordo74 View Post
      So does this work for Mavericks now for those of us with a Developer account?
      No- support will be added upon official release.
    1. madman1234's Avatar
      madman1234 -
      very nice. thanks!
    1. wavesequence's Avatar
      wavesequence -
      Assuming I' still have to install ML onto my new custoMacPro, what about the other people like me who created a Unibeast USB key with the previous Unibeast release and ML 10.8.3 installer?
      Do I need to erase everything and start from scratch?
    1. miv79's Avatar
      miv79 -
      Good job everyone, been holding out for this! Going to go make me a 10.8.4 installer right now...
    1. MacMan's Avatar
      MacMan -
      Quote Originally Posted by wavesequence View Post
      Assuming I' still have to install ML onto my new custoMacPro, what about the other people like me who created a Unibeast USB key with the previous Unibeast release and ML 10.8.3 installer?
      Do I need to erase everything and start from scratch?
      You don't need to do any unless you want to create a new 10.8.4 UniBeast stick.
    1. ulik's Avatar
      ulik -
      If I already have fully functional hack (with some minor glitches), running with the previous version of unibeast, how do I update to the new one without reinstalling everything? And Do I really need to update?
    1. LeadmaN's Avatar
      LeadmaN -
      @ulik

      You don't. Unibeast is meant to make a bootable USB stick to install OSX on your hardware. So you don't update your existing hack using Unibeast. That's what Multibeast is for.
    1. Tendersound's Avatar
      Tendersound -
      I just installed it on my USB 3.0 hard drive. Can't boot from it still due to being USB 3.0, whether I connect it to a USB 3.0 port or a USB 2.0 port.
    1. openmac's Avatar
      openmac -
      Nice
    1. nordemoniac's Avatar
      nordemoniac -
      USB 3.0 with any PCIe card?

      Anyone tested? I have a Lacie drive which I would love to get more than 25MB/s on.
    1. koki77's Avatar
      koki77 -
      Quote Originally Posted by Tendersound View Post
      I just installed it on my USB 3.0 hard drive. Can't boot from it still due to being USB 3.0, whether I connect it to a USB 3.0 port or a USB 2.0 port.
      I boot from USB 3.0 gigabyte efi plate
    1. heinzoliger's Avatar
      heinzoliger -
      is there a pb with the rss feed ? I received this article 40 times in feedly already : 2 each hours.
    1. tonymacx86's Avatar
      tonymacx86 -
      Quote Originally Posted by heinzoliger View Post
      is there a pb with the rss feed ? I received this article 40 times in feedly already : 2 each hours.
      Thanks for the report- we're attempting a fix.
    1. MagickHack83's Avatar
      MagickHack83 -
      So it's safe to assume that because of the updated drivers/kexts (ethernet and USB 3.0) that come pre-installed with this new version of unibeast, we no longer have to apply the configurations that come bundled with multi-beast? Thanks!